[FLOAT][FIRST-LETTER] firefox4 the floated first letter falls below, when a right floated div is around.

RESOLVED DUPLICATE of bug 594303

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 594303
8 years ago
8 years ago

People

(Reporter: hunboy, Unassigned)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

In FireFox 4b6 Gecko 2.0 the floated first letter falls below, when a right floated div is above and at right side.

Reproducible: Always

Steps to Reproduce:
1. add a div float:right;width:200px;height:100px;
2. put the long text into a paragraph
3. set the :first-letter as a drop cap for the paragraph
Actual Results:  
drop cap falls below the division

Expected Results:  
stay in a drop cap place

this is a new bug, seems only for gecko 2.0 firefox4.0b6
firefox3.6 works well
i just added it fastly for fixing before the final version comes out of ff4
(Reporter)

Updated

8 years ago
Version: unspecified → Other Branch

Comment 1

8 years ago
Test case ?

99% sure this is a dupe of bug 594303
(Reporter)

Comment 2

8 years ago
Created attachment 487204 [details]
testcase

Seems if the text of the parent element of the first-letter is longer than 1 line, the first-letter falls below the right-floated div. This situation is over, when the first letter is in a subelement (perhaps in a span or strong element which contains no longer text than 1 line)
The floating based on the first-letter's parent element width and not with his own width, in my experiences and as I show in the testcase.

But the calculated width for the :first-letter can't be so big. If we aspect the :first-letter as a child, it should be an inheritance bug of the calculated width value from parent, because it's actually the parent's width (what the floating algorythm sees), and not the own. Phisically it's just a pseudo element, not a real child in the DOM-tree, but must behave as a child with own width value.

this bug is only in firefox4
(Reporter)

Comment 3

8 years ago
hi philippe!

well yes its same :) thnx for the cooperation :)
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594303
(Reporter)

Comment 5

8 years ago
I've read now what David wrote over there. Really the width was the problem, what I tested basically in my testcase.
You need to log in before you can comment on or make changes to this bug.