Update script appears to clobber the pref to set the Mobile site/view up

VERIFIED FIXED in 2.0

Status

P2
major
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: stephend, Assigned: wenzel)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
It appears that, every time the update script runs on staging, we clobber the Django Admin pref that sets the Mobile site up correctly; we should fix that.

I'm not sure if that needs to happen in the update script itself or elsewhere -- punt as needed.
(Reporter)

Comment 1

8 years ago
Bug 608429 needs re-setting again; Fred/Dave -- can you guys fix this, please?
(Assignee)

Comment 2

8 years ago
I fixed the symptom, but for the root cause, Dave suggested adding a fix to our update_staging.sh script. Perhaps it'll be as simple as adding an entry to cron.py that'll check and update the database.
Priority: -- → P2
(Assignee)

Updated

8 years ago
Assignee: nobody → fwenzel
(Assignee)

Comment 3

8 years ago
Cron action added here: http://github.com/fwenzel/reporter/commit/aad142c

I also put that into our automatic staging update script.

The way it should work now is that every time the code is updated, the domains are also fixed. Note: The domains are hard-coded in the staging update script.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
Verified FIXED; the fact that we seem to continue to have updates a la cron, and that this pref remains (http://m.input.stage.mozilla.com/en-US/ is still the Mobile app), is awesome.

Thanks again, Fred!
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 596530
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.