All users were logged out of Bugzilla on October 13th, 2018

Mouse-over link doesn't show all URL types in status bar

VERIFIED FIXED in M9

Status

()

P2
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: mcafee, Assigned: joki)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MAKINGTEST] pglendinning@cen.com)

(Reporter)

Description

20 years ago
Mouse-over link doesn't show URL in status bar.
I use this a lot, to find out where I'm about to
go visit if I click.

Updated

20 years ago
Assignee: don → law
Priority: P3 → P2
Target Milestone: M6

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 1

20 years ago
Nisheeth was supposed to be adding support to the webshell to enable this in M6.
I'll see where that stands and if it's in place, I can code it up pretty
quickly, else we'll have to wait.

Comment 2

20 years ago
*** Bug 2928 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Target Milestone: M6 → M7

Comment 3

20 years ago
I'm moving this to M7.  It requires a bit more work than can be safely managed
for M6.

Updated

20 years ago
Component: Apprunner → Event Handling
QA Contact: leger → janc

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 4

20 years ago
This should be working in tomorrow's build (1999 Jun 09).

Updated

20 years ago
QA Contact: janc → elig

Comment 5

20 years ago
[QA Assigning to self for verification.]

Comment 6

20 years ago
Well...verifying on the 6.16.99 AM build [all 3 platforms, it works for HTTP
URLs.

However, it doesn't work for anything else I've tried, e.g.:
	* telnet URLs (e.g. such as on angalon.tamu.edu)
	* mailto URLs (e.g. such as on, say, people.netscape.com/sfraser)

Thus, I'm re-opening for mcafee's $.02.

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Target Milestone: M7 → M8

Comment 7

20 years ago
Let's handle the rest of these later ...

Updated

20 years ago
Resolution: FIXED → ---

Comment 8

20 years ago
The failure to display the URL for some links is a problem in the underlying
Gecko layout code or the nsWebShell.  This bug should be reassigned to reflect
that fact.

Updated

20 years ago
Assignee: law → joki
Status: REOPENED → NEW

Comment 9

20 years ago
Re-assigning to owner of this component.

Updated

20 years ago
Whiteboard: [MAKINGTEST] pglendinning@cen.com

Comment 10

20 years ago
Preliminary test case with 11 link types posted at
http://www.serve.com/apg/bugzilla/6086.html. The only links that seem to be
showing up in the status bar in M7(Win32) are about:, file: and http: links.
(Assignee)

Updated

20 years ago
Summary: Mouse-over link doesn't show URL in status bar → Mouse-over link doesn't show all URL types in status bar
(Assignee)

Comment 11

20 years ago
Moving this to M9, not high enough on my list for M8.

Updated

20 years ago
Target Milestone: M8 → M9

Comment 12

20 years ago
m9 move doesn't look like it took, tring again
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 13

20 years ago
I'm going to wait until Necko lands and see if this goes away.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

20 years ago
As hoped for this seems to magically work with the landing of Necko.

Comment 15

20 years ago
Verified fixed --- thanks to pglendinning@cen.com's excellent test case --- on
this morning's Mac OS & Win32 builds.

Will formally mark as verified when we have a Linux build that launches.

Comment 16

20 years ago
Verified fixed using 1999081001 Linux build.

However, I'm deferring to pglendinning@cen.com on verification, since I see
"[MAKINGTEST]" in the status, and would like to hold a bit if there's more he
intended to do.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 17

19 years ago
Stamping Verified, based on previous comments.
You need to log in before you can comment on or make changes to this bug.