"Script busy" message at different places when enabling/disabling jägermonkey - javascript.options.methodjit.content

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Daniel Kirsch, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101031 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101031 Firefox/4.0b8pre

When opening http://www.br-online.de/br-alpha/alpha-centauri/alpha-centauri-erdmagnetfeld-2001-ID1208426867571.xml I get a "script is busy" message pointing to a jQuery script in line 894 (there is a while loop).
When disabling javascript.options.methodjit.content I get the same message, but a different line: 589 where there is the return statement of a trim method:

trim: function(t){
 return t.replace(/^\s+|\s+$/g, "");
}, 

Other browser (Opera 10.62, Chrome 7.0.533, IE 9Beta1) do display the page and video without an error.

Even if the error is in the jQuery script the different lines when enabling and disabling Jägermonkey is strange to me.

Reproducible: Always
As Daniel mentioned to me it works with Firefox 3.6. So this is a regression on trunk. Would be great to get a regression window.

I can also see this script error on OS X. Confirming bug.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk

Updated

8 years ago
blocking2.0: ? → beta8+
(Reporter)

Comment 2

8 years ago
Here comes the range:

Works:
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre
Built from http://hg.mozilla.org/mozilla-central/rev/d253c44465ae

Broken:
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101027 Firefox/4.0b8pre
Built from http://hg.mozilla.org/mozilla-central/rev/2f456d0310fa


http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d253c44465ae&tochange=2f456d0310fa
Looks like it's one of the patches from the tracemonkey landing.
Assignee: general → dmandelin
Regressing changeset:

changeset:   55720:5feb11557dae
user:        Nicholas Nethercote <nnethercote@mozilla.com>
date:        Wed Oct 20 22:16:03 2010 -0700
summary:     Bug 600127 - nanojit: do implicit constant propagation after guards (2nd attempt).  r=edwsmith.
Assignee: dmandelin → general
Keywords: regressionwindow-wanted
Blocks: 600127
Just a couple of hours ago I landed a patch which fixed some problems relating to bug 600127 -- see bug 607856 (which reports a similar problem) and bug 609129 (which fixed it).  

Daniel, can you try again with a build that includes the patch from bug 609129?
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> Daniel, can you try again with a build that includes the patch from bug 609129?

OK. I will try the new nightly.
(In reply to comment #6)
> (In reply to comment #5)
> > Daniel, can you try again with a build that includes the patch from bug 609129?
> 
> OK. I will try the new nightly.

Daniel, is it fixed in todays nightly?
(Reporter)

Comment 8

8 years ago
Works for me now with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101105 Firefox/4.0b8pre
Marking this one as fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Hm, so bug 609129 hasn't been landed yet. Nicholas, which other patch could have fixed this bug for the latest nightly builds?
(In reply to comment #9)
> Hm, so bug 609129 hasn't been landed yet. Nicholas, which other patch could
> have fixed this bug for the latest nightly builds?

Has bug 607856 landed?  That added a workaround fix for the problem introduced in bug 600127, and bug 609129 fixed it properly.  I thought neither had landed yet on mozilla-central, though.

If neither of those have landed, I have no idea why it would now work.
No, neither of those bugs have been landed on m-c. Daniel, so the problem is gone for sure?
(Reporter)

Comment 12

8 years ago
At least the page I've pointed to and where the script busy message appeared works correct again and no message appears anymore.

You may try it yourself with a broken release from 20101027 and a working one from today 20101109. (Both, today's version and the version from 20101105 work for me)
You need to log in before you can comment on or make changes to this bug.