Scrolling: Mouse, Up/Down arrows, and PgUp/PgDn not same

VERIFIED DUPLICATE of bug 7354

Status

()

P3
minor
VERIFIED DUPLICATE of bug 7354
20 years ago
20 years ago

People

(Reporter: egregious, Assigned: joki)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
M5 doesn't handle scrolling via mouse scrollbar, pgup/pgdn, and arrow keys the
same on essentially stock RH 5.2 (2.2.4 tho).  (using the glibc binary)

Scroll bar works as expected with mouse but using up arrow and down arrw
(keyboard keys) introduces screen artifacts (repetition of the same line
two-three times before moving on a repeating the next line or so about 2-3 times
- more repetitions the faster the scroll seems to be executed.  Scrolling using
the mouse/scrollbar combo will clear the artifacts once they have been scrolled
past.  Using PgUp/PgDn keys will result in a scroll of the expected length but
with the bottom third (approx) unrendered (just default grey).  Going down then
up will sometimes produce similar unrendered parts in top and bottom third of
screen).  Had a similar problem with 4.0-4.04 on NT that went away in 4.05 (and
probably totally unrelated)

Comment 1

20 years ago
*** Bug 6146 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

20 years ago
*** This bug has been marked as a duplicate of 7354 ***

Updated

20 years ago
Target Milestone: M7

Updated

20 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.