Last Comment Bug 608730 - Push Socorro 1.7.5 to production
: Push Socorro 1.7.5 to production
Status: VERIFIED FIXED
11/07/2010 @ 7pm
:
Product: Infrastructure & Operations
Classification: Other
Component: WebOps: Other (show other bugs)
: other
: All Other
: -- normal (vote)
: ---
Assigned To: Justin Dow [:jabba]
: matthew zeier [:mrz]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-01 08:22 PDT by Laura Thomson :laura
Modified: 2013-10-09 10:29 PDT (History)
9 users (show)
mzeier: needs‑downtime+
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---
Cab Review: ServiceNow Change Request (use flag)


Attachments

Description Laura Thomson :laura 2010-11-01 08:22:32 PDT
It's not tagged yet, but has been through QA (waiting on fixes for a couple of regressions they found) so hopefully we'll tag it today.

mrz, trying to get a feel for when we might get a window this week?  Tuesday or Thursday?
Comment 1 Justin Dow [:jabba] 2010-11-01 09:24:56 PDT
Tuesday works for me. Thursday night I'll be en route back from Phoenix.
Comment 2 matthew zeier [:mrz] 2010-11-02 11:25:34 PDT
I didn't announce this last night - does it involve user downtime?
Comment 3 Laura Thomson :laura 2010-11-02 12:52:32 PDT
There will be one user-facing impact - the topcrashers by version/signature will be partially unavailable for (estimated) 4 hours while the data is being regenerated by the updateTopCrashes script. 

I'm ok with holding off until Thursday so we can get a downtime notice out.
Comment 4 matthew zeier [:mrz] 2010-11-02 13:02:25 PDT
Thursday is out.  Wednesday is the only time this week that would work.  

Jabba/Laura - work?
Comment 5 Laura Thomson :laura 2010-11-02 13:34:04 PDT
Wednesday is good for me, and Jabba said yes in IRC.
Comment 6 Laura Thomson :laura 2010-11-03 09:17:02 PDT
The tag is
https://socorro.googlecode.com/svn/tags/releases/1.7.5_r2680_20101103/

Jabba: please begin by 
- backing up code (to a tarball)
- configs (to a .old or whatever you like)
- dumping the TCBS table as a backup 

You will find all other details here:
https://intranet.mozilla.org/Socorro_Releases
Comment 7 Laura Thomson :laura 2010-11-08 07:16:11 PST
Didn't go ahead last night I take it?  When's the next window?  Tuesday?
Comment 8 Justin Dow [:jabba] 2010-11-08 14:37:44 PST
Did the push last night. A few minor tweaks were done this morning, but the system is up and generally stable.
Comment 9 Stephen Donner [:stephend] 2010-11-09 09:41:50 PST
Verified FIXED on http://crash-stats.mozilla.com; I tested several 1.7.5 fixes, on prod.

Note You need to log in before you can comment on or make changes to this bug.