Never show remote content from site

RESOLVED FIXED in Thunderbird 31.0

Status

--
enhancement
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: carleeto, Unassigned)

Tracking

unspecified
Thunderbird 31.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 953426])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101027 Lightning/1.0b2 Thunderbird/3.1.6

When you view an email with remote content (images etc), Thunderbird says that it has blocked remote content from the site to protect your privacy. There is also a link that says "Always show remote content from <site>"

The problem is that frequently the remote content provides no extra information and can safely be ignored. However, the text in the email is still valuable information - about new products, pricing, updates, etc. 

Now, if you don't want the remote content loaded, when Thunderbird prompts you to load remote content, you will do nothing. Which means the next time a message comes from the same site, you get prompted again. This can get quite frustrating when you have a lot of messages to get through. 

What I'm asking for is a way to tell thunderbird not to prompt me to show remote content for every message from a specific site. The simplest way I can think of it is a link you can click on that says "never load remote content from <site>".

Reproducible: Always

Steps to Reproduce:
1. Sign up for update emails from a few sites like Apple, Microsoft, etc
2. Wait for an email that contains remote content to arrive
3. Try to tell Thunderbird that you want it to never load remote content from that specific site.
Actual Results:  
You can't.

Expected Results:  
If there is a way to tell it to always load remote content, there should be a way to tell it to never load remote content.
Whiteboard: dupme?
Status: UNCONFIRMED → NEW
Component: General → Mail Window Front End
Ever confirmed: true
QA Contact: general → front-end
Whiteboard: dupme?

Updated

7 years ago
Duplicate of this bug: 720551

Comment 2

5 years ago
I am surprised at the lack of activity on this bug for the last 3 1/2 years. This message (that Thunderbird has blocked remote images) is annoying. For privacy reasons, I never want to see remote images (aka web beacons if used on a website...). 

This message takes up precious vertical space on the preview pane, making it necessary to open the email in a separate tab to actually see all the information at once (in some emails). 

I wish for a simple switch (hidden in about:config if necessary) to say "never show the remote images have been hidden message". Or, failing that, a button on the message itself per-email address as suggested in the initial bug report.
Depends on: 457296

Comment 3

5 years ago
And apparently that hidden switch does exist. Look for, in about:config:  
permissions.default.image 
change from 1 to 2. 
Information from this article: http://kb.mozillazine.org/Permissions.default.image
That article being related to /browsers/ (e.g. Firefox and Seamonkey) rather than Thunderbird, but the switch seems to work. 

This change will make it so that no remote images will load in emails, and no message will show. It also probably prevents images loading in other contexts within Thunderbird, but I don't know.
Bug 953426 fixed this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
OS: Windows Vista → All
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: [fixed by bug 953426]
Target Milestone: --- → Thunderbird 31.0
You need to log in before you can comment on or make changes to this bug.