Available updates pane shown needlessly after installing a restart-less add-on

VERIFIED FIXED in mozilla2.0b8

Status

()

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
mozilla2.0b8
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 591024][AOMTestday])

(Reporter)

Description

8 years ago
STR:

1. Open about:addons.
2. Install a restartless add-on.

As soon as the installation is finished, the add-on is added to the list, and the "Available Updates" pane is shown.  If you click on that pane, you'll get a message saying "No updates found".
(Reporter)

Comment 1

8 years ago
The pane will not re-appear if you close and reopen about:addons.
Ehsan, have you selected to install all updates for add-on manually? If yes, it is a dupe of bug 591024.
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Ehsan, have you selected to install all updates for add-on manually? If yes, it
> is a dupe of bug 591024.

I just chose to install an add-on from an xpi file from local disk.  No updates were involved in the process whatsoever.
Confirmed (thought I saw this the other day, didn't get a chance to investigate). Nothing in the error console.

As a guess, its probably something to do with the onInstallEnded handler in gUpdatesView.
Don't think it is a dupe but it might be fixed by bug 591024
Depends on: 591024
Whiteboard: [could be fixed by bug 591024][AOMTestday]
Duplicate of this bug: 616624
Is it fixed by the patch on bug 591024?
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101212 Firefox/4.0b8pre

Dave, now that it is fixed by bug 591024, is it worth another test or not?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite?
Flags: in-litmus-
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: [could be fixed by bug 591024][AOMTestday] → [fixed by bug 591024][AOMTestday]
Target Milestone: --- → mozilla2.0b8
Status: RESOLVED → VERIFIED
I believe that the test from bug 591024 covers this case enough
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.