With installed de-at xpi the preferences open incomplete

VERIFIED FIXED

Status

Mozilla Localizations
de / German
P3
major
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Matti, Assigned: Robert Kaiser)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build 2000112004 / Win2k (DE) / Athlon 650 / 320MB RAM

I have installed the localisation XPI de-at for the nightly builds from
http://www.kairo.at/mozilla,
(file)-=> http://www.hirsch.sth.ac.at/mozilla/de-AT.xpi.

If I open the preferences directly after open Mozilla the preferences open
incomplete and I get 2 console warnings
(look at the attachment)
If I open the preferenes after I had load a File or URL first,
the preferneces open fine.
If I switch back to english I haven´t this problem.

This seems not to be a bug of the XPI File (Kairos comment)
(Reporter)

Comment 1

17 years ago
Created attachment 19578 [details]
screenshot with console and the uncomplete opend preferences
not a problem after i installed 2000.11.21.08 [comm verif bits, installer blob]
on win2k. i18n/l10n problem?
Assignee: dveditz → nhotta
Component: Preferences: Backend → Internationalization
QA Contact: sairuh → teruko

Comment 3

17 years ago
Reassign to tao.
Assignee: nhotta → tao

Comment 4

17 years ago
--> Robert :-)
Assignee: tao → KaiRo
(Assignee)

Comment 5

17 years ago
hmm, this problem definately doesn't come from my L10n files, I discussed about
this problem with Matti on IRC a ling time...
If he opens the window after having a page loaded, he gets the window correctly,
with all the strings (and I don't do more than changing strings with this locale).
He gets the bug only when he is "fast enough" at opening the pref window.

I'm not sure where this bug is originating but I assume if could be pref
backend, that's why he filed the bug there... :)

I'm not able to deal with that issue.

Matti: what start page setting do you have? does moz load about:blank or a web
page on startup? Does this also happen if you switch back to en-US?
(Assignee)

Comment 6

17 years ago
btw, this worksforme in my 2000-11-20-06-Mtrunk linux with de-AT locale and
LCARStrek skin applied.
(Reporter)

Comment 7

17 years ago
My first comment is wrong.
I see this problem also if I had loaded a page/file.

If I run mozilla with -console, I see this incomplete preferences.
If I close this incomplete prefernces dialog and reopen the preferences, the
preferences dialog comming up completely.
If I load mozilla without -console and open the preferences, mozilla hang
before I see the preferences dialog.

If I switched my sidebar on, I haven´t this problem !!
If I switch back to en-US I also haven´t this problem !

I have deleted my old mozilla build and my profile directory.
And I deleted my mozregistry.dat in c:\winnt.
After that I had uncompressed the talkback-Win32.zip, created a new profile and
installed the de-AT.
If I switch now to de-AT and switch off my sidebar, I have this problem.

(Assignee)

Comment 8

17 years ago
Hmm, I don't understand this problem, can't reproduce it and have no clue where
it's coming from...
I'm almost sure it doesn't come from my localised files - but maybe it shows up
if you select a localization different from en-US, like your description tells.
I'm sure I can't resolve this bug without knowing what's going on there... and
as long as I can't see it (wfm).

Anyone knowing what could happen here?
(Assignee)

Comment 10

17 years ago
Tao, thx. I didn't realize the differences between the platform-specific files
are that big...
I'll look into it - though I dislike the idea of having at least two .xpi files
for de-AT. Why is it called "cross platform" [install|architecture|anything] then???
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

17 years ago
Depends on: 61863
(Assignee)

Comment 11

17 years ago
I'm currently creating all those XPI files on Linux, derived from Linux Mozilla
nightlies, as I'm very rarely using Windows nowadays.
That's why Windows is missing some entities in this .dtd file. I filed bug 61863
for the L10n issue we ran in here. I think it's bad if we have to provide
different XPI packages for every platform, but that's what we currently would
have to do.

This bug won't fix as long as Mozilla's current platform specific structure
doesn't chage and I don't use en-US.jar Windows version as a source for those
XPI packs :(
(Assignee)

Updated

17 years ago
Depends on: 61626
No longer depends on: 61863
(Assignee)

Comment 12

17 years ago
hmm, I perhaps should also tell you what I've done :)

as 61863 was marked a dupe of 61626, I also changed dependency reflectiong this...
(Assignee)

Comment 13

17 years ago
Just realised this should go into component for de-AT...
Component: Internationalization → German-Austria/de-AT
Product: Browser → Browser Localizations
Version: other → unspecified

Comment 14

17 years ago
Changed QA contact to laurasl@netscape.com.
QA Contact: teruko → laurasl
This error occurs for me as well!
Nightly Mozilla (2001020904) and nightly de-at translation.
(Assignee)

Comment 16

17 years ago
Because of bug 61626, this happens to everyone on windows using nightly de-AT
packs (created from linux builds).
As we already have stated, this shouldn't be the case, and it will get fixed
with 61626.
BTW: Mozilla 0.7 de-AT German pack was produced from a win32 version and
therefore doesn't have this problem.
Sorry, I won't change my OS because of this bug, and I don't have the time to
boot windows, download a different build and create localisation for it that
often. Until 61626 is fixed, you have to live with that bug when using de-AT
nightly packs. sorry.
(Assignee)

Comment 17

17 years ago
Hmm, could someone on win32 try this with a nightly build/pack 2001-03-18-09 or
later?
This should be fixed now (note bug 72501 - platform specific texts are
untranslated). I'll mark it fixed, reopen it when it is still happening, verify
when it's really solved.
Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

17 years ago
verified fixed with 2001031904 / win2k + nightly de-at.xpi for build 2001031809
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.