ERROR addons.xpi: Error creating statement getAddonsInLocation

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: ashah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

384.00 KB, application/octet-stream
Details
(Reporter)

Description

7 years ago
I just updated my minefield to yesterdays nightly and I am getting this on the error console.

Error: ERROR addons.xpi: Error creating statement getAddonsInLocation (SELECT internal_id, id, location, version, type, internalName, updateURL, updateKey, optionsURL, aboutURL, iconURL, icon64URL, defaultLocale, visible, active, userDisabled, appDisabled, pendingUninstall, descriptor, installDate, updateDate, applyBackgroundUpdates, bootstrap, skinnable, size, sourceURI, releaseNotesURI FROM addon WHERE location=:location)


Actual result: I cannot see anything being typed into the url bar. For eg. If I try typin google.com, I can see the results in the awesome bar but I cannot see anything being typed into URL bar. Also minefield does not refresh on any content. I have to take the focus away to another window and then get the focus back n minefield again to refresh content.
Duplicate of this bug: 609057
Could you attach a copy of extensions.sqlite from your profile folder and tell me what the value of extensions.databaseSchema is
(Reporter)

Comment 3

7 years ago
Created attachment 487647 [details]
extensions.sqlite file
(Reporter)

Comment 4

7 years ago
The value of extensions.databaseSchema is 3
Have you recently used an older nightly (before September) or beta (b7 or earlier) with this profile? If so did you happen to crash when you first ran that older build?
(Reporter)

Comment 6

7 years ago
No. I have been using this profile specifically for minefield. I just update my minefield when I start it (I dont update it everyday though). My update before this was 3 days ago and that worked fine.
Have you installed or uninstalled any extensions recently or even opened the add-ons manager?
(Reporter)

Comment 8

7 years ago
yes. I did open the addons manager to see which extensions are installed currently. I didnt install anything though
extensions.sqlite has been replaced by extensions.json in bug 853388, so this problem can no longer occur.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.