Set default action to be Open for the helper app dialog if a helper app is present

VERIFIED FIXED

Status

SeaMonkey
UI Design
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [branch accept])

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
This bug came out of a phone call discussion with some real audio folks today.

Currently, when the helper app dialog is invoked, we currently preselect the
Save To Disk radio button.

If you want to open using a helper app you have to click the open radio button
every time.

Desired behavior: If we've detected the presence of a helper app to use, then we
should default the dialog to have "Open" pre-selected.
methinks this is the default action in 4.x...
Keywords: 4xp
OS: Windows NT → All
QA Contact: sairuh → shrir
Hardware: PC → All
(Assignee)

Comment 2

18 years ago
Adding some real audio folks to the cc list as they are interested in this bug. 
Status: NEW → ASSIGNED
(Assignee)

Comment 3

18 years ago
Created attachment 19760 [details] [diff] [review]
proposed fix
(Assignee)

Comment 4

18 years ago
Here's the proposed fix. When we bring up the helper app dialog, if we detect
that we already have a helper app to initialize the dialog with then be sure to
preselect the Open radio button instead of the Save To Disk radio button. 

Comment 5

18 years ago
Which file types/mime types/helper apps does this happen for?  I wouldn't want 
the default action to be "open" for excel spreadsheets, which can contain 
scripts, or for zip archives, since my handler for .zip decompresses into the 
current directory without prompting.
(Assignee)

Comment 6

18 years ago
the default action doesn't mean you don't get the helper app dialog, we just
start it off with the Open With "Excel" radio button selected by default instead
of Save To Disk.

The user still gets a dialog and they can change it to save to disk before any
harm is done. 

Comment 7

18 years ago
looks good
sr=alecf
(Assignee)

Comment 9

18 years ago
I just checked in the fix for this into the trunk. If a helper app is present,
the dialog always defaults to "Open". Otherwise it defaults to "Save To Disk".

Thanks for the code reviews guys. 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
Scott, please check this in on the branch ASAP.
Whiteboard: [branch accept]
(Assignee)

Comment 11

18 years ago
done (this has been landed on the branch)

Comment 12

18 years ago
verified on trunk(1211) and branch (1211) builds that this is working as 
expected.
Status: RESOLVED → VERIFIED
*** Bug 62637 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.