If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

'search by signature' not working on Prod

VERIFIED FIXED in 1.7.6

Status

Socorro
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: vish_moz, Assigned: ryansnyder)

Tracking

({regression})

Trunk
1.7.6
regression
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
STR:
1. go to prod site http://crash-stats.mozilla.com/products/Firefox
2. in the search box enter some signature like UserCallWinProcCheckWow and hit enter

Expected result:
list of all reports with that signature

Actual result:
Advanced Filters page

Note: On the Advanced filters page if you click 'Filter Crash Reports' button then you do get the expected result

Comment 1

7 years ago
Ryan: will your patch for bug 606073 fix this too?
Assignee: nobody → ryan
Nope, this is broken on stage as well.
Target Milestone: --- → 1.7.5
Keywords: regression

Updated

7 years ago
Target Milestone: 1.7.5 → 1.7.6
I think this is because, by default, it includes the "Version" parameter with the value of "Firefox", which seems bogus (should be all):

http://crash-stats.stage.mozilla.com/query/query?do_query=1&product=Firefox&version=Firefox%3A&query_search=signature&query_type=exact&query=HeapDestroy

Where the below works (literally just pressing "Filter Crash Reports" seems to clean up the query):

http://crash-stats.stage.mozilla.com/query/query?product=Firefox&version=ALL%3AALL&range_value=1&range_unit=weeks&date=11%2F11%2F2010+02%3A57%3A20&query_search=signature&query_type=exact&query=HeapDestroy&build_id=&process_type=any&hang_type=any&do_query=1
Flags: in-testsuite?
Flags: in-litmus?
Duplicate of this bug: 613379
Committing for 1.7.6. This includes a lot of refactoring that was slated for the 1.8 release.

==

Sending        webapp-php/application/controllers/query.php
Sending        webapp-php/application/controllers/report.php
Sending        webapp-php/application/libraries/crash.php
Sending        webapp-php/application/models/common.php
Sending        webapp-php/application/views/layout.php
Transmitting file data .....
Committed revision 2775.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

7 years ago
This has fixed 'searching by signature' for Firefox but not for other products
like Thunderbird, Camino etc.
Reopening the bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The default quick search displays results specific to the product that has been selected in the navigation bar.  

If you perform the following steps, you quick search will return results:
1. Set product to Camino in navigation bar
2. Wait for page to reload
3. Once page has reloaded insert CFArrayGetCount in the search window and hit Return
4. You will see 1 result

If this logic is considered a bug, please open a new ticket.  Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
> The default quick search displays results specific to the product that has been
> selected in the navigation bar.  
> 
> If you perform the following steps, you quick search will return results:
> 1. Set product to Camino in navigation bar
> 2. Wait for page to reload
> 3. Once page has reloaded insert CFArrayGetCount in the search window and hit
> Return
> 4. You will see 1 result
> 
> If this logic is considered a bug, please open a new ticket.  Thanks!

It works for some signatures like,CFArrayGetCount.
but if you pick Thunderbird and search for  mozcrt19.dll@8f8d, @90417c2
or JS_TraceChildren it will not. New Bug 613651 has been filed for this.
(Reporter)

Comment 9

7 years ago
Verified, FIXED.
Status: RESOLVED → VERIFIED
Thanks Vishal!
Flags: in-testsuite?
Flags: in-testsuite+
Flags: in-litmus?
Flags: in-litmus+
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.