The "gripper" to resize the window on Mac OS X interferes with items in the add-on bar

RESOLVED FIXED in Firefox 4.0b12

Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Thomas, Assigned: dao)

Tracking

Trunk
Firefox 4.0b12
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [addon bar][target-betaN][softblocker])

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101102 Firefox/4.0b8pre
Build Identifier: 

On Firefox 4 there is a new add-on bar and widgets created with the Jetpack SDK are placed on its right.

On Mac OS X, this is also the only corner where the user can resize the window, there is a little "gripper". Unfortunately, it is placed over the widget even if it's not visible. Consequently, it's impossible to click on about half the widget's surface.

Reproducible: Always

Steps to Reproduce:
1. Install an extension create with Jetpack and displaying a widget.
2. Try to click on the bottom-right of the icon.
Actual Results:  
Nothing happens, the onClick event is not fired.

Expected Results:  
onClick event should be fired and the associated code should be executed.
(Reporter)

Comment 1

7 years ago
Created attachment 487719 [details]
The red triangle reveals the zone where we can't click
Confirmed on beta7 build 1. Also, where is the gripper image? :/
Status: UNCONFIRMED → NEW
Ever confirmed: true
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
This needs to be fixed in Firefox, since it applies to any add-on in the bar, not just Jetpack-built add-ons.
Component: General → Toolbars
Product: Add-on SDK → Firefox
QA Contact: general → toolbars
Target Milestone: -- → ---
Version: unspecified → Trunk
Summary: The "gripper" to resize the window on Mac OS X interferes with the first Jetpack SDK's widget → The "gripper" to resize the window on Mac OS X interferes with items in the add-on bar
Whiteboard: [addon bar]
It is not only related to the add-on bar. For the Sync error messages, the close button is in that area and only the small top portion of it can be clicked.
Whiteboard: [addon bar] → [addon bar][target-betaN]
Duplicate of this bug: 628113
(Assignee)

Comment 7

7 years ago
We need to make sure #status-bar is the right-most element. This is important for the resizer on Win XP as well.
Assignee: nobody → dao
(Assignee)

Comment 8

7 years ago
Ehsan, which side does this effect in RTL windows on OS X, i.e. is the gripper on the left or on the right?

Comment 9

7 years ago
(In reply to comment #8)
> Ehsan, which side does this effect in RTL windows on OS X, i.e. is the gripper
> on the left or on the right?

It is currently on the right side, but that's a bug (filed as bug 631729).  That said, the add-on icons appear on the left side in LTR mode for me, so I can't reproduce this bug in its original version in comment 0.

When I switch to RTL mode, the resizer stays on left, and the add-on bar icons move to the right, but again they don't overlap with the window resizer...

So, in short, I'm not sure how to answer comment 8, but I would love to provide a better answer if you can lead me on how to reproduce this problem.
(Assignee)

Comment 10

7 years ago
Created attachment 509996 [details] [diff] [review]
patch
Attachment #509996 - Flags: review?(enndeakin)

Updated

7 years ago
Attachment #509996 - Flags: review?(enndeakin) → review+
(Assignee)

Updated

7 years ago
Attachment #509996 - Flags: approval2.0?
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
Attachment #509996 - Flags: approval2.0? → approval2.0+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
(Assignee)

Comment 11

7 years ago
http://hg.mozilla.org/mozilla-central/rev/5a096b270075
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
Why does this add a ridiculous ordinal to the statusbar element? That doesn't seem necessary to fix this problem.

In addition, I know for a fact there are people who want to be able to move the statusbar element around, by placing toolbar elements on either side of it, and doing this effectively kills that ability.

Also, have you confirmed that doing this won't cause issues like Bug 602971?
(Assignee)

Comment 13

7 years ago
(In reply to comment #12)
> Why does this add a ridiculous ordinal to the statusbar element? That doesn't
> seem necessary to fix this problem.

See comment 7.

> Also, have you confirmed that doing this won't cause issues like Bug 602971?

No, as that bug is news to me. I'll take a look at your example extension right now.

Comment 14

7 years ago
The new ordinal value also affects the add-on Nosquint.  The zoom percentage is now fixed to the very right of the status bar.  Before, I could move it around relative to the other icons on the statusbar.
Depends on: 632022
Posthumous blocking+.
blocking2.0: ? → final+
Whiteboard: [addon bar][target-betaN] → [addon bar][target-betaN][softblocker]
Duplicate of this bug: 632477
You need to log in before you can comment on or make changes to this bug.