Last Comment Bug 60921 - Radio button dots remain when unselected
: Radio button dots remain when unselected
Status: VERIFIED WORKSFORME
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Windows 2000
: P3 major (vote)
: ---
Assigned To: Johnny Stenback (:jst, jst@mozilla.com)
: Jan Carpenter
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 17:53 PST by Ken Mori
Modified: 2001-03-21 17:38 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase comparing html and javascript created radio buttons (904 bytes, text/html)
2000-11-22 05:39 PST, Conor Lennon
no flags Details
testcase similar to previous but with radio buttons grouped by name (1.23 KB, text/html)
2000-11-22 08:01 PST, Tim Powell
no flags Details

Description Ken Mori 2000-11-21 17:53:58 PST
In certain cases (not all, I haven't tracked down the exact conditions)when you 
dynamically create a group of radio buttons using createElement("INPUT"), when 
another radio button in the group is selected, the selected radio button has a 
dot and the circle around it looks raised.  However on the unselected button, 
the circle around it correctly turn inset but the dot remains.
Comment 1 Johnny Stenback (:jst, jst@mozilla.com) 2000-11-22 02:08:32 PST
A testcase that shows this problem would be greatly appreciated, thanks!
Comment 2 Conor Lennon 2000-11-22 05:39:03 PST
The circle around the radio button changes as it no longer has focus.
As far as I can see the behaviour of radio buttons created with the
createElement function is correct.
I have a testcase which compares the behaviour of radio buttons created with
html and createElement()
Comment 3 Conor Lennon 2000-11-22 05:39:49 PST
Created attachment 19616 [details]
testcase comparing html and javascript created radio buttons
Comment 4 Tim Powell 2000-11-22 08:01:34 PST
Created attachment 19619 [details]
testcase similar to previous but with radio buttons grouped by name
Comment 5 Fabian Guisset 2000-11-22 11:37:32 PST
Worksforme build2000111820 win32. Are you still seeing this?
Fabian.
Comment 6 Ken Mori 2000-11-22 11:53:51 PST
Yes I am. But I haven’t had time (and I’ll be on vacation for the next few 
weeks) to create a test case.  It happens in only certain situations and I 
haven’t been able to isolate the “certain situation” except in the context of 
our complete code (which in no yet accessible publicly).
Its very weird.  Since the radio buttons change there up/down situation, it 
appears that the browser recognized the radio button is being unselected but it 
simply does not clear the dot.
Comment 7 Johnny Stenback (:jst, jst@mozilla.com) 2000-11-28 04:18:42 PST
Marking WORKSFORME, please reopen when there's a testcase that shows the
described problem.
Comment 8 Fabian Guisset 2000-12-14 07:34:21 PST
Might be fixed (if there was a problem) by rods checkin for radiobuttons
Comment 9 Stephen Walker 2001-02-13 18:47:50 PST
marking verified using the 2001021020 nightly on win2k.

Note You need to log in before you can comment on or make changes to this bug.