Flash videos in fullscreen mode create an extra null tab

RESOLVED DUPLICATE of bug 583782

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 583782
8 years ago
8 years ago

People

(Reporter: vladmaniac, Unassigned)

Tracking

(Blocks: 1 bug, {polish})

Trunk
x86
Windows 7
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 487868 [details]
screenshot

Build ID: 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101102 Firefox/4.0b8pre

=========================================================================
Prerequisites: 
1. Clean profile
2. Two monitors - this is not quite necessary, but since in fullscreen mode, 
it helps you actually see that weird tab 
3. Flash plugin installed 

=========================================================================
Steps: 
1. Visit http://www.axn.ro/full-episodes
2. Play the video 
3. Enter fullscreen mode, from the player controls. NOT from Firefox (that is F11) 
4. Inspect window's task bar 

=========================================================================
Behavior: 
An extra null tab appears in windows 7's task bar. This tab is separate from 
Firefox queue of opened windows, and has no icon. 

Note the error in the console: 
Error: aTab is null
Source File: chrome://browser/content/tabbrowser.xml
Line: 1797

See screenshot of the "weird" tab

Updated

8 years ago
Blocks: 236647
jmathies, should this block? I wonder how this could interact with Panorama or session restore.

Comment 2

8 years ago
(In reply to comment #1)
> jmathies, should this block? I wonder how this could interact with Panorama or
> session restore.

I don't think so, it's passive. Just an extra icon on the taskbar when flash is in full screen mode on dual monitor setups. We could touch this up by adding the fx icon to the plugin container exe or better, find someone with a setup like this to work on it.
Keywords: polish

Comment 3

8 years ago
We actually fixed this for the single monitor case AFAIK, we propagate the app modal id over the secondary process. It's tough to test to see if that's working though.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583782
You need to log in before you can comment on or make changes to this bug.