"A script on this page may be busy" ... "Script: chrome://global/content/appPicker.js:154"

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Rob, Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)

Under Windows XP, the Operating System's "right click on file in explorer.exe" select "open with" and choose submenu "choose program" feature can have a very long delay before the "Open With" Dialog is presented. It is extra slow the first time you do it after a fresh reboot.


If you visit this Page:

Bulldozer Processor Topology Explained
http://blogs.amd.com/work/2010/10/29/bulldozer-processor-topology-explained/

there is a link to a video here: http://videos.amddevmedia.com/bulldozer/BulldozerFinalwebstream.mp4 if you click it then (it would have been nice if VLC had opened it since I have the plug-in but that was not to be) you can choose "Other" but after some time this Dialog will popup:

-----

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://global/content/appPicker.js:154

[Continue] [Stop Script]

-----

IF you [Continue] the Script twice (sometimes three times) then the Windows XP Operating System's "Open With" Dialog will (finally) appear and you can choose VLC. Control then returns to Firefox, the file is downloaded and then opened in VLC.


Thanks,
Rob


Reproducible: Always
(Reporter)

Comment 1

7 years ago
This also has occurred before startup (before "Plug-in Compatibility Check Dialog") twice while my OS was under load.


Occurs on this Platform too:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13pre) Gecko/20101112 Namoroka/3.6.13pre ( .NET CLR 3.5.30729; .NET4.0E)

Rob
(Reporter)

Comment 2

7 years ago
Here is were it hangs on Namoroka (20101126033208) and Firefox (20101026202021) prior to startup:

Script: file:///C:/Program%20Files/Namoroka/components/nsExtensionManager.js:5995
Script: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsExtensionManager.js:5994

It seems to happen maybe 1 in 12-15 times.

Rob
(Reporter)

Comment 3

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Namoroka/3.6.13pre Firefox.3.6 ( .NET CLR 3.5.30729; .NET4.0E)

In order to trigger this popup for certain try this URL. It will trigger this same message several times and ruins the usage of the Site:

V8 Benchmark Suite - version 6
http://v8.googlecode.com/svn/data/benchmarks/v6/run.html


When you run the Benchmark you get this message repeatedly:

"
A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: http://v8.googlecode.com/svn/data/benchmarks/v6/raytrace.js:226
"


We need to turn down the sensitivity of the detection to allow legitimate Scripts to run without interruption.

Thanks,
Rob
Severity: normal → major
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> We need to turn down the sensitivity of the detection to allow legitimate
> Scripts to run without interruption.
Indeed, the author's Site is unusable (at 1x1 resolution): http://labs.flog.co.nz/raytracer/ you need to restart the Script every 20 seconds.

Rob

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 5

7 years ago
Just for reference, because I am snowed down under other things, I have gotten the error message 

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://tavgp/content/libs/include.js:572

every time upon starting Firefox 3.x.16.  I'm not sure about the x because I just tried to update to Firefox 4.  I don't know where the problem comes from.  

My computer refuses to update to Firefox 4, claiming that another version of Firefox might be running.  I tried ending it in Task Manager several times to no effect.  But eventually, after hitting the Firefox button on my desktop several times it started back up with Firefox 3.6.16.  And no message about the include.js error.  We'll see what happens next.

Comment 6

7 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> Reporter -> Are you still experiencing this issue with the latest version of
> Firefox 5? Does the issue occur with the latest nightly?
> http://nightly.mozilla.org/

Yes, sometimes. 

If I open FF 7 under WinDbg I can see it several times before FF starts.
(Reporter)

Comment 8

7 years ago
I get the popup a dozen times on this Page http://www.msi.com/product/nb/WindPad-110W.html#?div=FAQ when I restart after a crash (in FF7) without running under the Debugger.

Comment 9

7 years ago
Please attach the contents from about:support as a text attachment to this report
Version: 3.6 Branch → 7 Branch
(Reporter)

Comment 10

7 years ago
Created attachment 553431 [details]
This is 'about:support' from Aurora 7.0a2 (2011-08-15).

> Please attach the contents from about:support as a text attachment to this report.

Comment 11

7 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

I was unable to REPO by goint to the url in comment 8 - crashing Firefox and re-opening Firefox
(Reporter)

Comment 12

7 years ago
(In reply to Tim (fmdeveloper) from comment #11)
> Does the issue still occur if you start Firefox in Safe Mode?
> http://support.mozilla.com/en-US/kb/Safe+Mode
> 
> I was unable to REPO by goint to the url in comment 8 - crashing Firefox and
> re-opening Firefox

The example in comment 8 no longer exhibits the behavior so it is no long a reproducible example using that URL.


I did see the complaint in comment 0 ('sometimes "chrome://???/???.js" files hang') occur as little as three weeks ago. It happened OFTEN up until a couple of months ago (and prior 9 months). Currently it seldom occurs. 

If I don't see it at all in the next two months I am going to close this; as it is probably related to Bug 620978 ("timesharing of JS with Browser's other tasks is unfairly implemented" - thus letting JS hang us).
(Reporter)

Comment 13

7 years ago
These "A script on this page may be busy" Popups are especially bad when starting Nightly under WinDbg; understandable but annoying, and really really annoying when there are two or three dozen of them.

One trick to reduce (but not always eliminate them) is to start Nightly WITHOUT using WinDbg, let it load completely then close it, now run WinDbg and load Nightly; sometimes this can eliminate the Popups altogether.

BUT, this Bug is about getting the Popups WITHOUT debugging, though using WinDbg helps to produce them and show which ones are most likely to hit a timeout, thus allowing those particular '.js' files to get some optimization or have their timeouts extended.


The popups still rarely occur (without using WinDbg), perhaps if the persons testing used WinDbg they could spot the worst offenders and then they would never occur under normal usage.


PS: My Computer is a half dozen years old (somewhat slow) and I'm waiting for the super Computers coming out in 2012. People with a more recent Computer may not be able to reproduce this Bug.
(Reporter)

Comment 15

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #14)
> you can increase the script timeout time. But 
> http://kb.mozillazine.org/Script_busy_or_stopped_responding

Rob, do any of
> the bugs in this list -
> https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=anywordssubstr&list_id=1387235...

Yowl, that is quite a long list. If I had to chose one quickly then perhaps: https://bugzilla.mozilla.org/show_bug.cgi?id=640742 and 
ONLY because it is assigned (if your looking for a 'better Dupe'). None of the Reports seem aimed at an INTERNAL COMPONENT and are
more about "JavaScript on the Page (visited Site)".

If I search for:
https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=anywordssubstr&short_desc=apppicker&field0-0-0=short_desc&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=enhancement&resolution=---&resolution=FIXED&resolution=INVALID&resolution=DUPLICATE&resolution=WORKSFORME&classification=Client%20Software&classification=Components&chfieldto=Now&query_format=advanced&chfieldfrom=2007-01-01&short_desc_type=substring&type0-0-0=nowords&value0-0-0=count%20counts&field1-0-0=short_desc&list_id=1424581
then MY Report is the ONLY one that comes up thus mine is unique in that way (and that it is "our" Javascript (an internal component)
and not some unkown JavaScript on some WebSite somewhere. I do agree (with some of the other Reports) that there ARE Sites that
you can Visit that do cause the Popup but (for me) these are rare (and I test quite thouroughly).

Some of those Reports are not complete enough to know if they are the same as mine and some Reports claim it only happens
on ONE Site (thus different from mine); whereas MY Report is for the FIRST run of "appPicker.js" (which is also a slow Process 
WITHOUT using Firefox, once the cache is built (in Windows) then Windows is quicker on subsequent runs of Microsoft's "AppPicker"). 

Firefox is 'fast enough' (doesn't trigger the popup) on any subsequent runs of AppPicker (after the first).

So I do not see a "true" Dupe in that List.

I will use your suggestion and increase the Value by 50%, thanks for the Tip.

Rob
(Reporter)

Comment 16

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #14)
> you can increase the script timeout time. But 
> http://kb.mozillazine.org/Script_busy_or_stopped_responding
> 
> Rob, do any of ...
I increased the limit by 300% to 60 and now I have not seen any problems in the last 2 weeks. I am going to decrease it to 40.

Comment 17

6 years ago
Rob -> Any update?
(Reporter)

Comment 18

6 years ago
(In reply to Tim (fmdeveloper) from comment #17)
> Rob -> Any update?

Very rare. Last seen weeks ago but not on "appPicker.js". 

Closing as WFM since even reopening many Tabs at once no longer jams FF.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.