Firefox doesn't support relative URIs in <base> tag

VERIFIED DUPLICATE of bug 515401

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 515401
7 years ago
7 years ago

People

(Reporter: randy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1

If an HTML page contains:
  <base href="stuff/">
  <script src="code.js"></script>

such that, relative to the web page, code.js is located in a "subfolder" called "stuff"

FF will not process the base tag properly.  Safari/Webkit correctly resolves the (relative) base tag using the page's absolute URI, and then resolves the script's src to the resolved base tag.

Reproducible: Always
You'll need to wait for Firefox 4. Relative base URIs are a new feature of HTML5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 515401
(Reporter)

Comment 2

7 years ago
This has nothing to do with bug 515401.  The content in the description appears in the head.  There is only one base tag in the page, but FF doesn't handle it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Please retest with Firefox 4 Beta or nightly. Relative base URIs are a new feature of HTML5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 515401
verified dupe of bug 515401
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.