If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[CBX]SPACE in OPTION VALUE= tag makes form fail

VERIFIED INVALID

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Chris Bitmead, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001119
BuildID:    2000111908

If you have an OPTION tag inside of a SELECT in a form,
and if the VALUE="foobar    " has spaces in it, then
the browser doesn't appear to return any value for that form
element. This makes certain web pages die a horrible death. (Yes there are good
reasons to have a space in the VALUE attribute.)

Reproducible: Always
Steps to Reproduce:
Create a form with a select and option...
<SELECT>
<OPTION VALUE="foobar   ">FOOBAR</OPTION>
</SELECT>
(I am using a FORM with POST method if that matters)
Now in the cgi or servlet (I'm using java servlet) the form element will not be
in the request attributes. But if I use IE it will all be fine. If I take out
the spaces it will be there. (But due to the application, we need the spaces there).

Actual Results:  Servlet crashes due to form element not existing.

Expected Results:  Return the value for the selected element.
*** Bug 60940 has been marked as a duplicate of this bug. ***
Um...  The <select> needs a name.  Once I add one, the form submits with no
problems and I see a value on the server end.  linux build 2000-11-19-21.

Do you still see the problem after adding a name attribute to the <select>

If so, could you attach a testcase to this bug?
(Assignee)

Comment 3

17 years ago
Yes, a name is required. Works this way in 4.x
(Assignee)

Updated

17 years ago
Summary: SPACE in OPTION VALUE= tag makes form fail → [CBX]SPACE in OPTION VALUE= tag makes form fail
Chris, do you still see a bug here after adding a name for the select?

Comment 5

17 years ago
marking invalid unless we hear back from the reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 6

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.