Last Comment Bug 609401 - "Section [Build] not found" spammed to the terminal
: "Section [Build] not found" spammed to the terminal
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Justin Lebar (not reading bugmail)
:
Mentors:
Depends on:
Blocks: 607946
  Show dependency treegraph
 
Reported: 2010-11-03 14:54 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2011-05-19 14:52 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.52 KB, patch)
2011-05-18 09:24 PDT, Justin Lebar (not reading bugmail)
no flags Details | Diff | Review
Patch v2 (3.51 KB, patch)
2011-05-18 13:15 PDT, Justin Lebar (not reading bugmail)
ted: review+
Details | Diff | Review

Description Ryan VanderMeulen [:RyanVM] 2010-11-03 14:54:36 PDT
Something changed in the last day that's causing this to get spammed a lot when building at least on Windows.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-11-06 18:23:07 PDT
This is really obnoxious.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-11-06 18:51:47 PDT
Looks like this gets spammed from printconfigsetting.py.  Not sure how we're firing that off in every directory.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-11-06 19:54:16 PDT
j'accuse http://hg.mozilla.org/mozilla-central/rev/39a979e26931

the export forces BUILDID to be evaluated each pass through which causes this.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2010-11-07 13:13:55 PST
Yeah, lame. I can probably just make that a shell variable setting in the rule command.
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-04-06 13:38:11 PDT
Justin, if you wanted an easy-ish build system to work on you could take this one.
Comment 6 Justin Lebar (not reading bugmail) 2011-04-10 15:34:16 PDT
This is Windows-only?  If so, I won't be able to hack on it until I get a Windows machine in a few weeks...
Comment 7 Daniel Holbert [:dholbert] 2011-04-10 16:25:31 PDT
(In reply to comment #6)
> This is Windows-only?  If so, I won't be able to hack on it until I get a
> Windows machine in a few weeks...

No -- this happens on Linux & Mac, too.  I see it locally all the time, and it also shows up in build logs on tinderbox. (Just search for "Section [" in any recent TryServer build log, for example.)
Comment 8 Justin Wood (:Callek) 2011-04-10 16:48:19 PDT
It only happens on clobber builds, fwiw
Comment 9 Justin Lebar (not reading bugmail) 2011-05-18 09:14:54 PDT
Ah, the reason I didn't see it in comment 6 is that I had my patch for bug 620285 applied, which apparently fixes this problem.  I think I have a fix.
Comment 10 Justin Lebar (not reading bugmail) 2011-05-18 09:24:42 PDT
Created attachment 533303 [details] [diff] [review]
Patch v1

This fixes the spam, although I don't know if breaks something else...
Comment 11 Justin Lebar (not reading bugmail) 2011-05-18 09:31:01 PDT
Comment on attachment 533303 [details] [diff] [review]
Patch v1

... actually, it only fixes the problem if you don't know how to use grep.

I think it's the right approach, though.
Comment 12 Justin Lebar (not reading bugmail) 2011-05-18 12:44:02 PDT
So comments 9 through 11 are wrong. But also, I think, is comment 3 -- if I comment out the SYMBOL_INDEX_NAME definition, I still get the warnings.
Comment 13 Justin Lebar (not reading bugmail) 2011-05-18 13:15:39 PDT
Created attachment 533392 [details] [diff] [review]
Patch v2

Okay, this seems to work.  Comment 12 was wrong again -- the problem was what Kyle suggested in comment 3, but my patch queue was messing with things.

How can I test that I didn't mess up upload_symbols.sh?  I guess I could push to try, download the build, and make sure that I'm able to retrieve symbols from the symbol server?
Comment 14 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-18 13:26:02 PDT
Comment on attachment 533392 [details] [diff] [review]
Patch v2

I'm going to give this one to ted since symbol upload scares me.
Comment 15 Ted Mielczarek [:ted.mielczarek] 2011-05-19 08:31:35 PDT
Comment on attachment 533392 [details] [diff] [review]
Patch v2

Review of attachment 533392 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/crashreporter/tools/upload_symbols.sh
@@ +61,1 @@
>  : ${SYMBOL_SERVER_HOST?} ${SYMBOL_SERVER_USER?} ${SYMBOL_SERVER_PATH?} ${1?"You must specify a symbol archive to upload"}

Move your variable assignments below this block (which errors if things are unset), and change the ${1 there to ${2, and add a new ${1 to error if the symbol index name isn't given.
Comment 16 Justin Lebar (not reading bugmail) 2011-05-19 13:29:40 PDT
Ah, thanks for catching that!  I totally glossed over that line.
Comment 17 Justin Lebar (not reading bugmail) 2011-05-19 14:52:37 PDT
http://hg.mozilla.org/mozilla-central/rev/99436764a926

Note You need to log in before you can comment on or make changes to this bug.