SeaMonkey compatibility should reflect reality

VERIFIED FIXED

Status

Cloud Services
Firefox Sync: Backend
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Igor Velkov, Assigned: rnewman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 488087 [details] [diff] [review]
pull SeaMonkey compatibility up to 2.1b

Seamonkey compatibility info should be pulled up to 2.1b
(Reporter)

Updated

8 years ago
Attachment #488087 - Flags: review?(philipp)
Attachment #488087 - Attachment is patch: true
Attachment #488087 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 488087 [details] [diff] [review]
pull SeaMonkey compatibility up to 2.1b

Isn't Sync going to be included in SeaMonkey 2.1? If so, we don't want to declare 2.1 compatibility just yet. When it eventually ships, SeaMonkey might ship with a newer version than what we release now (and its UI might depend on that newer version), so we really don't want to declare the add-on compatible with future releases.
Attachment #488087 - Flags: review?(philipp) → review-
(Reporter)

Comment 2

8 years ago
oops. Mistyping.
2.1b should be.
What about 2.1b?
(In reply to comment #2)
> What about 2.1b?

I'm not even sure that works as a wildcard, but if it does, the same problem applies.
SeaMonkey 2.1 will in fact include Sync out of the box. SM RC 1 is expected today and SM 2.1 final is to arrive probably next week. SM 2.0 will be discontinued soon (in line with FF 3.5, both of which were released from Mozilla 1.9.1) but especially for the transitional phase we'd like to provide SM users with a working Sync version for SM 2.0, too.

I think we should be pragmatic here and do the following to minimize the effort and maximize the outcome:

1. Mark all Firefox Sync versions after 1.5.1 as not compatible with SeaMonkey (any version) on AMO. Reasoning: I checked that 1.5.1 works with SM 2.0.x. Don't know about 1.6 (see below; better safe than sorry), but 1.7 is broken for sure.

The following thread suggests that at least some versions of Firefox Sync 1.6 did not work correctly with SeaMonkey:
<http://groups.google.com/group/mozilla-labs-weave/browse_thread/thread/9e5f7a2fce904a15>

2. Close bug 649758 and bug 641322 (as duplicates of this one if you want).
(Assignee)

Comment 5

7 years ago
(In reply to comment #4)
> SeaMonkey 2.1 will in fact include Sync out of the box. SM RC 1 is expected
> today and SM 2.1 final is to arrive probably next week. SM 2.0 will be
> discontinued soon (in line with FF 3.5, both of which were released from
> Mozilla 1.9.1) but especially for the transitional phase we'd like to
> provide SM users with a working Sync version for SM 2.0, too.

There is no way to sync a storage version 5 client (built-in Sync in recent Firefox) with storage version 3 (add-on 1.5.1). If your goal is to allow people to gradually migrate between SeaMonkey versions, this is not the way to achieve it.

Whichever client upgrades first will upgrade the server account; other clients will then be automatically locked out.

This is not a big deal; when clients upgrade, they will join the set of synced devices as if they were new.

We're broadly unwilling to roll a new add-on release if we can help it.

> I think we should be pragmatic here and do the following to minimize the
> effort and maximize the outcome:
> 
> 1. Mark all Firefox Sync versions after 1.5.1 as not compatible with
> SeaMonkey (any version) on AMO. Reasoning: I checked that 1.5.1 works with
> SM 2.0.x. Don't know about 1.6 (see below; better safe than sorry), but 1.7
> is broken for sure.

You can do that, but I don't know if there's much point in encouraging users to use a buggy, outdated version rather than to upgrade SeaMonkey.

There are *lots* of bookmarks and other fixes since 1.5.1.
(In reply to comment #5)
> > I think we should be pragmatic here and do the following to minimize the
> > effort and maximize the outcome:
> > 
> > 1. Mark all Firefox Sync versions after 1.5.1 as not compatible with
> > SeaMonkey (any version) on AMO. Reasoning: I checked that 1.5.1 works with
> > SM 2.0.x. Don't know about 1.6 (see below; better safe than sorry), but 1.7
> > is broken for sure.
> 
> You can do that, but I don't know if there's much point in encouraging users
> to use a buggy, outdated version rather than to upgrade SeaMonkey.

I do (or will) encourage users to upgrade to SM 2.1. But that's not the point. The point is that AMO advertises versions of the Firefox Sync add-on to SeaMonkey users that do not work with any version of SeaMonkey. And as far as I know AMO, if you remove SeaMonkey compatibility for the current version of the add-on, it will appear as unsupported to SeaMonkey users. People who know what they are doing can still go to "View all versions", though, but that's OK. SeaMonkey is all about making suggestions rather than enforcing things.

With my proposed changes applied, the last version of the add-on that worked with SM 2.0 will be available, though not advertised, and no version of the add-on will be available for SM 2.1 (for obvious reasons, and like it is now).

> There are *lots* of bookmarks and other fixes since 1.5.1.

First of all, SM 2.0 has no Places-based bookmarks, so the Sync support for bookmarks doesn't matter there; the point is moot.

Secondly, of course people using SM 2.1 will get all of these fixes. But I firmly believe that people staying on SM 2.0 for a while, for whatever reason, should have a chance to use something usable and be able to upgrade later (with all data collected until that time) rather than installing something that is broken (on SM). After all there's no security issue involved here (as far as Sync is concerned) so it should really be the user's choice.

After all we're just talking about letting the compatibility on AMO reflect reality. No code changes, no promises of better support, in short: No real downsides. If I could have done that change myself I would have done it right away--it's really that easy a decision from my POV. Deal? :-)
(Assignee)

Comment 7

7 years ago
(In reply to comment #6)

> After all we're just talking about letting the compatibility on AMO reflect
> reality. No code changes, no promises of better support, in short: No real
> downsides.

That's fine by me, so long as you're aware of all the angles (e.g., that SM2.0 + 1.5.1 will be unable to sync after a user tries out SM2.1).
(In reply to comment #7)
> (In reply to comment #6)
> 
> > After all we're just talking about letting the compatibility on AMO reflect
> > reality. No code changes, no promises of better support, in short: No real
> > downsides.
> 
> That's fine by me, so long as you're aware of all the angles (e.g., that
> SM2.0 + 1.5.1 will be unable to sync after a user tries out SM2.1).

Just for future reference, Jens is not a SeaMonkey Council member, *but* I stick my rubber stamp on this choice/plan, *as* a SeaMonkey Council Member. [incase anyone questions it]
(In reply to comment #7)
> (In reply to comment #6)
> 
> > After all we're just talking about letting the compatibility on AMO reflect
> > reality. No code changes, no promises of better support, in short: No real
> > downsides.
> 
> That's fine by me

So... Who can do this, now that we have an agreement? I'd gladly contact anyone with the appropriate rights for updating AMO.
(Assignee)

Comment 10

7 years ago
(In reply to comment #9)

> So... Who can do this, now that we have an agreement? I'd gladly contact
> anyone with the appropriate rights for updating AMO.

I can do it.

Before I do, though: if I mark an add-on version as incompatible, what behavior will users who have that version installed see in SeaMonkey? Will it be automatically disabled? Prompt to upgrade?

I just want to make sure that they don't get b0rked because we missed a case. If you say "no problem", I'll change the flags on AMO tonight.
(In reply to comment #10)
> Before I do, though: if I mark an add-on version as incompatible, what
> behavior will users who have that version installed see in SeaMonkey? Will
> it be automatically disabled? Prompt to upgrade?

It might get disabled the next time they do an add-ons update check, but I doubt it will be upgraded since there is no newer (higher) version that has compatibility, only a lower one (1.5.1).

Anyway, the versions above 1.5.1 do not work with SeaMonkey, so either the people having those versions installed take action (like uninstalling and reinstalling another version, which would only work for them if they chose 1.5.1 or lower) or they stay on the broken versions. In any case it doesn't get worse. The benefit however would be that people having the newer versions installed might be informed (when looking at the AOM) that it is in fact not compatible, and people looking at AMO will no longer be tricked into installing the versions that are in fact not compatible.

As Callek pointed out, I'm not a Council member, but he is and already agreed in comment 8.
Summary: Seamonkey compatibility info should be pulled up to 2.1b → SeaMonkey compatibility should reflect reality
(Assignee)

Comment 12

7 years ago
Done:

  https://addons.mozilla.org/en-US/firefox/addon/firefox-sync/versions/

Please verify and set resolution if all is well.
Assignee: nobody → rnewman
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
I have Firefox Sync 1.5.1 installed and no longer get an update announcement, as expected. TUVM!
Status: RESOLVED → VERIFIED
Thanks for this,
But I run Sync 1.6.3 with SM 2.0.14 just fine (ok, just for passord sync, no cookies, no history, no bookmarks), then why choosing 1.5.1 ? 
What about all people that had already upgraded to 1.6.x ?
(In reply to comment #14)
> But I run Sync 1.6.3 with SM 2.0.14 just fine (ok, just for passord sync, no
> cookies, no history, no bookmarks), then why choosing 1.5.1 ? 

Hmm, seems you are right. I thought it broke after 1.5, and I haven't checked earlier 1.6 versions either, but 1.6.3 seems to work, including the Preferences integration. Anyway, 1.5.1 works just as well, so not much is lost. The main purpose of this bug was to not advertise incompatible versions as compatible. I might have failed to select the best version, but then I would have had to check all 1.6.x versions, too. And AFAIR at least one of them was broken (for SM).

> What about all people that had already upgraded to 1.6.x ?

There shouldn't be much of a difference. With 1.6.3 installed, the add-on won't get disabled or uninstalled, because only the AMO compatibility was changed, not the one included in the file. You won't get an update announcement, but that's what we want (1.7 is incompatible and the official upgrade path is SM 2.1 which includes Sync out-of-the-box). People (still) running older 1.6.x versions won't get an update, too, but that's OK since none of this is officially supported anyway (i.e. they can upgrade to 1.6.3 manually or better directly to SM 2.1).
You need to log in before you can comment on or make changes to this bug.