app.update.url details not found

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Usul, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

8 years ago
I'm having a update stuck at 25% download. I don't think it's related but the error console contains the following text :

Error: formatURLPref: Couldn't get pref: app.update.url.details
Source File: jar:file:///data/app/org/mozilla.fennec.apk!/components/nsURLFormatter.js Line: 145

buildt from m-c b192fa5cfffc (as I didn't find anything else to identify the build then to use about:buildconfig)
That preference provided by each app so moving to fennec.
Component: Application Update → General
Product: Toolkit → Fennec
QA Contact: application.update → general
The error above is not fatal. The nsUpdaterService.js code checks for the preference in a try/catch block. app.update.url.details is an optional preference.

http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/nsUpdateService.js#1002

Fennec does not provide the pref
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

8 years ago
Mark the issue is that the console gets filed with these error making finding more interesting error a bit more difficult.
Duplicate of this bug: 613526
You need to log in before you can comment on or make changes to this bug.