DOM has changed in FF 3.6

RESOLVED DUPLICATE of bug 224788

Status

()

RESOLVED DUPLICATE of bug 224788
8 years ago
8 years ago

People

(Reporter: sdkahler1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.21022; InfoPath.2; .NET CLR 3.5.30428; .NET CLR 1.1.4322; .NET CLR 3.0.30618; .NET CLR 3.5.30729; MS-RTC LM 8)
Build Identifier: 3.6.12

The following javascript code worked in versions of FF before 3.6 and doean't work anymore.    Why ?   Is this going to be fixed ?   It appears that the Document object model has changed.
            if ((divs[i].parentElement.pathname != undefined && 
(divs[i].parentElement.pathname.indexOf("pushin hover") >= 0 || 
divs[i].parentElement.pathname.indexOf("pushpin hover") >= 0)) || 
(divs[i].className == "" && divs[i].innerHTML.substr(0, 6) == "<SPAN>"))
		    {
		        if (divs[i].innerHTML.substr(0, 6) != "<LABEL" && 
divs[i].innerHTML.substr(0, 11) != "<DIV style=")
		        {
		            // iEle.href = divs[i].outerHTML;
		            pEle = new pushPinElement();
		            var s1 = divs[i].innerHTML;
		            if (divs[i].innerHTML.substr(0,5) != "<SPAN")
		            {
		                var c1 = s1.indexOf("http:");
		                var c2 = s1.indexOf('"',c1);
		                pEle.href = s1.substring(c1,c2);
		            }   
		            else
		            {
		                pEle.href = s1;
		            }
		            if (divs[i].innerHTML.substr(0, 6) == "<SPAN>") {
		                pEle.offsetLeft = 
                                  divs[i].offsetParent.offsetLeft;
		                pEle.offsetTop = divs[i].offsetParent.offsetTop;
		            }
		            else {
		                pEle.offsetLeft = 
                                     divs[i].parentElement.offsetLeft;
		                pEle.offsetTop = 
                                     divs[i].parentElement.offsetTop;
		            }
		            pEle.offsetHeight = divs[i].offsetHeight;
			    pEle.offsetWidth = divs[i].offsetWidth;
			    pushpinurls.push(pEle);
			    }
			}


Reproducible: Always

Steps to Reproduce:
1.Use parentElement.pathname in javascript
2.
3.
Actual Results:  
The code doesn't work anymore in FF 3.6.

Expected Results:  
The code doesn't work anymore in FF 3.6.

The code doesn't work anymore in FF 3.6.

Comment 1

8 years ago
parentElement is part of the MS DHTML DOM, not the standard W3C DOM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 224788
You need to log in before you can comment on or make changes to this bug.