Mobile feedback from 4.0b2 is being listed under desktop firefox feedback

VERIFIED FIXED in 2.0

Status

Input
General
--
major
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: aakashd, Assigned: davedash)

Tracking

Details

(Reporter)

Description

8 years ago
Steps to Reproduce:
1. go to http://input.mozilla.com/en-US/search/?q=&product=firefox&version=4.0b2&date_start=&date_end=
2. Look at the Platforms list

Actual Results:
Android and Maemo are listed under Firefox product. 

Expected Results:
All Android and Maemo feedback should be listed under the mobile product.
This involves cleaning the UA sniffing code *and* re-cleaning items in the DB since a few days ago.
I don't see any results, which tells me that the UA detection works correctly (also, Hudson not complaining tells me that too). Which is a good thing.

Compare that to:
http://input.mozilla.com/en-US/search/?q=&product=mobile&version=4.0b2&date_start=&date_end

... which shows a whole lot.

Based on this, I am lowering severity because neither our raw DB data seems messed up, nor do the opinions actually show up in the list -- they are just miscounted in the statistics on the side.

Dave: I think this is a bug that might already be fixed with the new faceted search. Can we find that out, and much better yet, test this (perhaps a test case that ensures Mobile data in the database will neither be returned in a search for Desktop nor counted in the stats)?
Assignee: nobody → dd
Severity: blocker → major
Target Milestone: --- → 2.0
(Reporter)

Comment 3

8 years ago
Another thing to note is that http://input.mozilla.com/en-US/search/?product=mobile&version=4.0b2&date_start=&date_end= was populating messages correctly after 4.0b2 for mobile was released. Then, it suddenly dropped. 

The system is working as aravind sent feedback and the opinion was registered with its own unique id. It just doesn't show up on that input query. 

Since it was working until 5pm and then feedback suddenly stopped being populated onto the dashboard, could there be a possibility that this is due to a cron script that ran at 5pm?
(Reporter)

Comment 4

8 years ago
> Since it was working until 5pm and then feedback suddenly stopped being
> populated onto the dashboard, could there be a possibility that this is due to
> a cron script that ran at 5pm?


Uh, it's fixed now? The messages are populating (even the ones that were missing after 5pm)
This is more than likely because of sphinx not being indexed.


I'd ask someone in IT.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Did some more search testing, seems to have fixed now.
Verified, FIXED.
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.