Firefox hang when an event "alert ()" is called and a tab is about to be moved.

VERIFIED DUPLICATE of bug 100180

Status

()

--
critical
VERIFIED DUPLICATE of bug 100180
8 years ago
8 years ago

People

(Reporter: wanderleizakaliak, Unassigned)

Tracking

({hang})

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Firefox trava completamente quando você arrasta uma aba ou a segura para mudar de lugar e um evento de "alert();" é chamado em qualquer aba.

Esse problema apresenta desde versões anteriores do Firefox.

Sugiro fazer o teste com o seguinte processo:
1 - Criar um "alert" dentro de um laço de repetição com intervalos em cada chamada do "alert();" no javascript.
2 - Clicar em uma aba e manter a segurando até que o "alert();" seja processado.

Indiferente se você arrasta ou apenas segura a aba. O navegador trava completamente só conseguindo ser fechando pelo gerenciador de tarefas do Windows.

Aguardo,
Wanderlei F. Zakaliak

Reproducible: Always

Steps to Reproduce:
Sugiro fazer o teste com o seguinte processo:

1 - Criar um "alert" dentro de um laço de repetição com intervalos em cada chamada do "alert();" no javascript.
2 - Clicar em uma aba e manter a segurando até que o "alert();" seja processado.

Actual Results:  
Firefox crashes completely. Just being closed by Windows Task Manager

Updated

8 years ago
Whiteboard: dupeme
Can you please tell us the crash id of the uploaded crash report? Therefore please check the following web page:

http://support.mozilla.com/en-US/kb/Mozilla+Crash+Reporter
Keywords: crash
Summary: Problem. Firefox crashes completely! When an event "alert ()" is called and a tab is about to be moved. → Firefox crashes when an event "alert ()" is called and a tab is about to be moved.
(Reporter)

Comment 2

8 years ago
Não tenho como pegar o ID do erro. Poís como falei. o Firefox só é fechado através do gerenciador de tarefas do windows. e quando inicio novamente o Firefox não aparece nada reportando erros passados.
(Reporter)

Comment 3

8 years ago
I can not get the error ID. Because as I said. Firefox will be closed only through the task manager of windows. and again when I start Firefox nothing appears reporting past mistakes.
So Firefox hangs and doesn't crash. Given that information it is a dupe of bug 100180.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Keywords: crash → hang
Resolution: --- → DUPLICATE
Summary: Firefox crashes when an event "alert ()" is called and a tab is about to be moved. → Firefox hang when an event "alert ()" is called and a tab is about to be moved.
Whiteboard: dupeme
Duplicate of bug: 100180
(Reporter)

Comment 5

8 years ago
This, it crashes completely.
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → Trunk
(Reporter)

Comment 7

8 years ago
Okay, actually there is a similar error that falls into the same problem!
>This, it crashes completely.
A freeze is not a crash. That are 2 different technical terms.
You need to log in before you can comment on or make changes to this bug.