Closed Bug 609895 Opened 11 years ago Closed 6 years ago

Crash at shutdown [@ nsTArray<nsHttpHeaderArray::nsEntry>::IndexOf<nsHttpAtom, nsHttpHeaderArray::nsEntry::MatchHeader>][@ nsHttpHeaderArray::LookupEntry]

Categories

(Core :: Networking: HTTP, defect)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1247982
Tracking Status
firefox11 --- affected
firefox12 --- affected

People

(Reporter: jdm, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [mobile-crash][native-crash:P4][necko-backlog])

Crash Data

Reported for Fennec 4.0b2.

http://crash-stats.mozilla.com/report/index/96b19170-7558-425e-a9ce-9d0132101104

Somehow we have a null entry in the header array?  I find that very difficult to believe.

Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	nsTArray<nsHttpHeaderArray::nsEntry>::IndexOf<nsHttpAtom, nsHttpHeaderArray::nsEntry::MatchHeader> 	nsTArray.h:331
1 	libxul.so 	nsHttpHeaderArray::LookupEntry 	netwerk/protocol/http/nsHttpHeaderArray.cpp:228
2 	libxul.so 	nsHttpHeaderArray::GetHeader 	netwerk/protocol/http/nsHttpHeaderArray.cpp:111
3 	libxul.so 	nsHttpChannel::AddCacheEntryHeaders 	netwerk/protocol/http/nsHttpResponseHead.h:83
4 	libxul.so 	nsHttpChannel::InitOfflineCacheEntry 	netwerk/protocol/http/nsHttpChannel.cpp:2929
5 	libxul.so 	nsHttpChannel::CallOnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:792
6 	libxul.so 	nsHttpChannel::ContinueOnStartRequest3 	netwerk/protocol/http/nsHttpChannel.cpp:3864
7 	libxul.so 	nsHttpChannel::ContinueOnStartRequest2 	netwerk/protocol/http/nsHttpChannel.cpp:3855
8 	libxul.so 	nsHttpChannel::OnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:3828
9 	libxul.so 	nsInputStreamPump::OnStateStart 	netwerk/base/src/nsInputStreamPump.cpp:441
10 	libxul.so 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:397
11 	libxul.so 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:112
12 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:609
13 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
14 	libxul.so 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:491
15 	libxul.so 	nsSocketTransportService::Shutdown 	netwerk/base/src/nsSocketTransportService2.cpp:465
16 	libxul.so 	nsIOService::SetOffline 	netwerk/base/src/nsIOService.cpp:729
17 	libxul.so 	nsIOService::Observe 	netwerk/base/src/nsIOService.cpp:920
18 	libxul.so 	nsObserverList::NotifyObservers 	xpcom/ds/nsObserverList.cpp:130
19 	libxul.so 	nsObserverService::NotifyObservers 	xpcom/ds/nsObserverService.cpp:182
20 	libxul.so 	nsXREDirProvider::DoShutdown 	toolkit/xre/nsXREDirProvider.cpp:798
21 	libxul.so 	ScopedXPCOMStartup::~ScopedXPCOMStartup 	toolkit/xre/nsAppRunner.cpp:1113
22 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3712
23 	fennec 	main 	mobile/app/nsBrowserApp.cpp:155
24 	libc-2.5.so 	libc-2.5.so@0x14973 	
25 	fennec 	Output 	mobile/app/nsBrowserApp.cpp:77
Severity: normal → critical
I was just hitting this crash in Fennec.
I was on Gmail, the connection was really bad (Mozilla Guest), so I reloaded, then Fennec crashed.
Crash Signature: [@ nsTArray<nsHttpHeaderArray::nsEntry>::IndexOf<nsHttpAtom, nsHttpHeaderArray::nsEntry::MatchHeader>] [@ nsHttpHeaderArray::LookupEntry]
Summary: Crash at shutdown [@ nsTArray<nsHttpHeaderArray::nsEntry>::IndexOf<nsHttpAtom, nsHttpHeaderArray::nsEntry::MatchHeader> → Crash at shutdown [@ nsTArray<nsHttpHeaderArray::nsEntry>::IndexOf<nsHttpAtom, nsHttpHeaderArray::nsEntry::MatchHeader>][@ nsHttpHeaderArray::LookupEntry]
Duplicate of this bug: 650399
Crash Signature: [@ nsTArray<nsHttpHeaderArray::nsEntry>::IndexOf<nsHttpAtom, nsHttpHeaderArray::nsEntry::MatchHeader>] [@ nsHttpHeaderArray::LookupEntry] → nsHttpHeaderArray::nsEntry::MatchHeader> | nsHttpHeaderArray::LookupEntry ] [@ nsTArray<nsHttpHeaderArray::nsEntry>::IndexOf<nsHttpAtom, nsHttpHeaderArray::nsEntry::MatchHeader>] [@ nsHttpHeaderArray::LookupEntry] [@ nsTArray<nsHttpHeaderArray::nsEntry,…
Whiteboard: [mobile-crash] → [mobile-crash][native-crash:P4]
OS: Mac OS X → Android
Hardware: x86 → ARM
Crash Signature: , nsHttpHeaderArray::nsEntry::MatchHeader> | nsHttpHeaderArray::LookupEntry ] → , nsHttpHeaderArray::nsEntry::MatchHeader> | nsHttpHeaderArray::LookupEntry ] [@ nsTArray<T>::IndexOf<T>] [@ nsTArray<T>::IndexOf<T> | nsHttpHeaderArray::LookupEntry ]
Whiteboard: [mobile-crash][native-crash:P4] → [mobile-crash][native-crash:P4][necko-backlog]
this should be fixed by bug 1247982.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247982
You need to log in before you can comment on or make changes to this bug.