browsing around the included url causes mozilla to segfault

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
18 years ago
15 years ago

People

(Reporter: meiso, Assigned: neeti)

Tracking

({crash})

Trunk
mozilla1.0
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
while viewing the above url (sometimes you need to view some of the "top 10"
pages by clicking on the relevant link), the following happens:

JavaScript error: 
http://www.tuplay.com/display.asp?s=h&i=32&p=9 line 35: event is not defined

JavaScript error: 
http://www.tuplay.com/display.asp?s=h&i=32&p=9 line 38: event is not defined

JavaScript error: 
http://www.tuplay.com/display.asp?s=h&i=32&p=9 line 35: event is not defined

JavaScript error: 
http://www.tuplay.com/display.asp?s=h&i=32&p=9 line 38: event is not defined

JavaScript error: 
http://www.tuplay.com/display.asp?s=h&i=32&p=9 line 35: event is not defined

JavaScript error: 
http://www.tuplay.com/display.asp?s=h&i=32&p=9 line 38: event is not defined

/usr/local/mozilla/run-mozilla.sh: line 72:  9091 Segmentation fault      $prog
${1+"$@"}

i'm using Build ID: 2000112206

Comment 1

18 years ago
Created attachment 19630 [details]
Linux stack trace  +  debug info

Comment 2

18 years ago
Confirming crash on Linux. Note: I was unable to reproduce it on WinNT.
Steps to reproduce:

1. Go to http://www.tuplay.com/display.asp?s=h&i=32&p=1
2. Click on the "MMX Technology" link  ---> CRASH


Note this link corresponds to the file

       http://www.tuplay.com/display.asp?s=h&i=32&p=9


mentioned in Simon's report above -

Comment 3

18 years ago
Created attachment 19631 [details]
HTML of the link that causes the crash

Comment 4

18 years ago
Note: the JavaScript errors are not relevant to the crash, I think.
The identifier "event" is used in the HTML only on MouseOver events, etc.; 
whereas the crash occurs during page load -


Reassigning to Networking because of the stack trace -
Assignee: rogerl → gagan
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Networking
Ever confirmed: true
QA Contact: pschwartau → tever

Updated

18 years ago
Keywords: crash

Updated

18 years ago
Assignee: gagan → neeti
Target Milestone: --- → mozilla1.0

Comment 5

18 years ago
Can qa please confirm if this is still happening? Lots of stuff 
(imagelib/http/cache) has changed recently that might have fixed this...

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
The given URL, http://www.tuplay.com/display.asp?s=h&i=32&p=1, is now 404.
Going to http://www.tuplay.com/ gives "Directory Listing Denied".

I saved the HTML from attachment id=19631 above, adding the tag

               <BASE HREF="http://www.tuplay.com/">. 

No crash using Mozilla nightly binaries 2001-04-12-14 on WinNT and Linux.
Marking WORKSFORME - 

Updated

16 years ago
QA Contact: tever → benc

Comment 7

15 years ago
VERIFIED/wfm.
I tried this in Win98, Mozilla 1.4RC
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.