Firefox on Android doesn't fill in passwords on mobile sites if they have been synced from the desktop

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: lucas.mitchell, Unassigned)

Tracking

Trunk
Other
Other

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.23 Safari/534.10
Build Identifier: Fennec/4.0b2

If I save a username and password combination in firefox on my desktop using the full, desktop version of a website (for example, http://www.facebook.com), and then sync that username/password combo to firefox on my Nexus One, firefox on Android isn't clever enough to know that it can use that saved password if it is redirected to the mobile version of the same site (e.g., http://touch.facebook.com).

The upshot is that on many websites, the only way to have firefox on android use my synced passwords is to try to get to the full, non-mobile version of the site, and on some sites (esp. gmail/google reader), this is impossible without somehow changing the user agent.

Reproducible: Always

Steps to Reproduce:
1. Using your desktop computer, go to a site that requires logging in and has both a desktop and a mobile version. (e.g., http://www.facebook.com)
2. Log in and have firefox save your username and password.
3. Sync passwords to firefox mobile using firefox sync
4. go to the same site using firefox mobile, and have it redirect you to the mobile version of the site
5. Try to log in.
Actual Results:  
Firefox for Android doesn't fill in your saved password.

Expected Results:  
Firefox for Android should have filled in the password.

Comment 1

8 years ago
Firefox's password manager splits sites based on their subdomain. foo.example.com and bar.example.com could be two different servers with different owners. It is not safe to assume that passwords can be shared between such sites.

Comment 2

8 years ago
MConner does this sound like something Sync would like to address?
I don't think it's an issue for the Sync code to address.  I suspect that for every case where this would be okay, there's another case where it would be the opposite.
I can't reproduce this. 09/02 Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.