with switch to tab, when hovering a link and in a new tab, displays moz-action:switchtab

VERIFIED DUPLICATE of bug 601060

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 601060
8 years ago
8 years ago

People

(Reporter: mcdavis941 (sporadically reading bugmail), Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [switch-to-tab])

(A fairly obscure nit, but FWIW) If you trigger the awesomebar switch-to-tab mechanism while in a blank tab, then click outside the autocomplete dropdown, then hover some other link, the over-link origin displays: moz-action:switchtab,someurl rather than the actual url of the current tab.

This seems to only happen if you start the sequence while you're in an empty tab.

STR: 
1 - Open some tab with a mozilla URL, for example
2 - Open a new and blank tab
3 - Make the empty tab be the current tab
4 - In the urlbar type 'mozi', which should open the awesomebar dropdown and show your other tab as a possible match
5 - Arrow down to the matching 'mozi' tab, but don't click it or press enter
6 - Click some neutral spot outside the awesomebar dropdown to close it
7 - Note that the urlbar now shows something like Switch to tab: http://www.mozilla.com/en-US/firefox/central/
8 - Hover any other link
9 - Note that the urlbar now shows something like moz-action:switchtab,http://www.mozilla.com/en-US/firefox/central/ (along with the link target)


Actual result:
- While hovering, the urlbar shows something like moz-action:switchtab,http://www.mozilla.com/en-US/firefox/central/

Expected result:
- When hovering a link, it's supposed to be telling the user the contents of the current tab (New Tab or something like that) along with the link target
- Or, if intentionally telling the user they were in the middle of switching tabs, then moz-action:switchtab could be replaced by something more comfort-inducing

Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b8pre) Gecko/20101105 Firefox/4.0b8pre

See also Bug 480350 and Bug 587908.
What I see is something like: http://grab.by/7fO1

And one thing that may be confusing is that that it persists even if you switch tabs, press ESC, or restart the application. It's not unsettling, though.

Comment 2

8 years ago
Dupe of bug 601060.
Duping to bug 601060.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601060
Whiteboard: [switch-to-tab]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.