All users were logged out of Bugzilla on October 13th, 2018

Typing in Mozmill cases on mozilla1.9.1 is broken

VERIFIED DUPLICATE of bug 572143

Status

VERIFIED DUPLICATE of bug 572143
8 years ago
2 years ago

People

(Reporter: abillings, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
While working on an AwesomeBar testcase, I noticed that text wasn't being typed into the location bar when AwesomeBar cases are run on 1.9.1 Firefox. These are working fine on Trunk and 1.9.2 when tested. I tested all of the AwesomeBar cases.

After some discussions on IRC, I also tried the password manager testcases that use controller.type() to type into textboxes in a window. These are also broken.

This was found on OS X 10.6 running Mozmill 1.5.1rc2.
(Reporter)

Updated

8 years ago
Blocks: 553618
(Reporter)

Comment 1

8 years ago
Created attachment 488622 [details]
Repro case using mozmill and mozmill-tests hg repo

Place this in your /firefox/testAwesomeBar directory or one at a similar depth
in your mozmill-tests repo and run it.

I didn't add an explicit assert of the failure but if you run it on 1.9.1, you
won't see a navigation to twitter. If you run it on 1.9.2, you will.
It looks like that something is broken with on your new box. We should investigate when you are in the office next week.
(Reporter)

Comment 3

8 years ago
Did you check this on other boxes to verify that this is a local problem only to me? What boxes did you check on? Remember, this is 1.9.1 only.
No one else complained about it and our results from the daily test-runs don't show any problems in that area. Even locally everything is fine. I have also never heard from that before. All that gives me the impression that it is a local issue on your box.
(Reporter)

Comment 5

8 years ago
Can you actually personally try it on your OS X 10.6 machine with the 1.9.1 branch in order to be sure?
Please see my last comment.
(Reporter)

Comment 7

8 years ago
Turns out that this is a focus problem with Firefox on 1.9.1. It doesn't grab focus when instantiated by mozmill, causing tests to fail if other applications are open. This is a known issue.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
Duping it to the mozmill bug causing the problem. Still probably won't fix it, but I want it findable just in case.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 572143
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.