animated gifs not playing correctly

RESOLVED DUPLICATE of bug 610107

Status

()

defect
RESOLVED DUPLICATE of bug 610107
9 years ago
9 years ago

People

(Reporter: ffux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2) Gecko/20100212 Gentoo
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2) Gecko/20100212 Gentoo

simple loop animation gifs like the bugzilla dinosaur head are flashing between one frame and transparent.

It appears to be showing just one frame (probably the first) and one transparent frame alternately. The animations have many frames.


Reproducible: Always

Steps to Reproduce:
1. http://www.solaire-chauffe-eau.info/flag_fr.gif
2. note blinking animation not smooth animation.

Actual Results:  
correct gif animation sequence

Expected Results:  
alternately first frame and transparent frame. Rest on animation not shown.


http://www.solaire-chauffe-eau.info/panneau-solaire-thermique.html#CESI

second example, the flag in the menu should be waving not flashing !

Comment 1

9 years ago
No problem here,
http://hg.mozilla.org/mozilla-central/rev/f7016571b472
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101104 Firefox/4.0b8pre ID:20101104025921
Reporter

Comment 2

9 years ago
I found that a cairo update was at the root of this, reverting to x11-libs/cairo-1.8.10 fixed the problem.

Since a similar issue also showed defects in svg rendering I'll mark this as a dupe.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610107
You need to log in before you can comment on or make changes to this bug.