Closed Bug 610136 Opened 11 years ago Closed 11 years ago

When reloading calendar appointments disappear

Categories

(Calendar :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 610152

People

(Reporter: rkaeppeler, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Lightning 1.0b2

When I click on one of my CalDav-calendars (Googlemail) and click on reload calendar it sometimes happens that all of my appointments disappear in the Lightning Calendar view.

The appointments are still in Google-Calendar and when I restart Thunderbird the appointments are shown again!

Reproducible: Sometimes

Steps to Reproduce:
See "Details" of problem description
I can confirm this with latest nightly build (Feb 01) of lightning and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b3pre Thunderbird/3.1.7

When reloading the remote calendars, all events and tasks of all or some calendars are disappearing in the calendar and task view. Subsequent reloads do not bring back the events. A restart of thunderbird is necessary.

The error console does not ahow any errors or warning during the reloads of the calendars.
How many calendars do you have, and of what type are they?

Could you enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor, and recheck if you see any error messages that might help?
I have 13 calendars, all of them ical files on a webdav server.
Enabling calendar.debug.log and calendar.debug.log.verbose does not help; there are still no messages in the error console.
I found out that lightning does not rewrite the entries of a remote calendar while reloading if the server sents a 304 (not modified) in response to the reload request. If the calendar file has changed on the server and the reload request is answered by the server with a 200 and a transfer of the calendar file, all entries of the file are correctly shown/refreshed. 

(Lightning: newest nightly (March 7th), TB: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.15) Gecko/20110303 Lightning/1.0b3pre Thunderbird/3.1.9)
Possibly a duplicate of bug 610152? Could you test the nightly from 2011-01-09 03:53:53 to see if the problem doesn't happen there?
Yes, with the build 09-Jan-2011 (07) 07:37 everything is fine (I didn't find a build with the time 03:53).
Ok, I'm marking this bug duplicate then, I've already commented on the bug that this one has additional info! Thanks for testing!
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610152
You need to log in before you can comment on or make changes to this bug.