Not all Googlemail Sub-Calendars supported in CalDav-Address

RESOLVED INVALID

Status

Calendar
Provider: CalDAV
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: supporter, Unassigned)

Tracking

Lightning 1.0b2
x86
Windows 7

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Lightning 1.0b2

In my Googlemail-Calendar, I have several Calendars, one for my personal appointments and another one e.g. for "Official Holidays" and "National Holidays".

The CalDav-Address with the Calendar-Identifier for my National Holiday Calendar looks like the following:

https://www.google.com/calendar/dav/de.german#holiday@group.v.calendar.google.com/events

When I add a CalDav-Calendar with this address I only get a little exclamation mark for this Calendar and Lightning does not display any appointment of this Calendar.

Maybe this is due to the #-Sign in the address? Please check and verify how this Bug could be solved!

Reproducible: Always

Steps to Reproduce:
See detailed problem description
(Reporter)

Updated

8 years ago
Version: unspecified → Lightning 1.0b2
Do you have write access to the holiday calendar from Google Calendar? If not this might be the reason why trying to get write access using CalDAV fails. If you just want to read calendars you don't need CalDAV access. Use the read-only iCalendar access provided by Google Calendar.
(Reporter)

Comment 2

8 years ago
Hhm, you are right, in this case I do NOT have write access, but I would expect to have these appointments displayed, even if I don't have write access.

By the way, thanks for the hint with iCalendar. I added the iCalendar(ICS) with the ICS-Address provided by Google Calendar and now it's working fine.

Maybe we should think about displaying appointments even if there is no write-access to the CalDav-Calendar.
Resolving invalid per previous comments. It is up to Google if they want to allow anonymous read-only access via CalDAV.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.