Closed Bug 610143 Opened 9 years ago Closed 9 years ago

Full-Day appointments are not displayed bold in Calendar-Navigator

Categories

(Calendar :: General, defect)

Lightning 1.0b2
x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: rkaeppeler, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Lightning 1.0b2

When I add an appointment to my calendar in the Calendar-View the correspoinding day is displayed bold in the little Calendar-Navigator in the left upper corner (where you can browse through months etc.)

But when I add a full-day appointment to my calendar this day is not displayed bold in the Calendar-Navigator.

I would expect that also this day is displayed bold.

Reproducible: Always



Expected Results:  
See detailed problem description
Version: unspecified → Lightning 1.0b2
The minimonth only shows bold font color if the corresponding day contain events marked as busy. By default new all day events are marked as free. You can change free/busy via Options > Show Time As in the event dialog.
Why all day events are marked as free by default (where as other events are marked as busy)?
I would be nice to
- be able to set in the preferences the default behavior for free/busy information 
- maybe have an easier access to the free/busy choice while creating an event (in the main window)
This would be a more comfortable way of definining how it should behave.

But in my opinion, full-day appointments are appointments as any other appointment and therefore why not show them bold?
You can change the default to busy by opening Tools > Options > Advanced > Config Editor. Search for the preference "calendar.allday.defaultTransparency" and change its value from "TRANSPARENT" to "OPAQUE".
(In reply to comment #4)
> You can change the default to busy by opening Tools > Options > Advanced >
> Config Editor. Search for the preference "calendar.allday.defaultTransparency"
> and change its value from "TRANSPARENT" to "OPAQUE".

Thanks, I was looking in the config editor but I had no clue it was this one. Anyway, in my opinion it should be "OPAQUE" by default, and possibly this default preference may be modified by the user in the preferences menu..
That's also my opinion!
But for now, I am happy with this setting ;-)
Sorry, we won't be changing this preference for now. Of course it depends on the use case, but someone with many events will often have every day marked bold. Since all day events are often used for things like "Vacation time here" or "im in the office these days", or "convention xy here", these are not appointments that should be shown to the user as busy. More important would be "meeting on this day at this time", or "meet with zx at this time".

Given the workaround is easy, I think its reasonable to close this bug as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.