Scrollable HTML elements lose sub-pixel rendering after scrolling their contents

RESOLVED DUPLICATE of bug 606075

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 606075
7 years ago
a year ago

People

(Reporter: Christophe Jacquet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

After scrolling the contents a "scrollable HTML element" (textarea or multiple select), the contents is repainted without sub-pixel rendering, thus looking ugly. A repaint with sub-pixel rendering enabled happens after switching tabs, or spontaneously after a while (say 4 seconds).

Note that the problem occurs when scrolling the *contents* of the element, not when scrolling the *web page*.

Reproducible: Always

Steps to Reproduce:
1. Open a page with a scrollable textarea, for instance an "edit" page on Wikipedia.
2. Scroll the contents of the textarea
Actual Results:  
The contents of the textarea is rendered with sub-pixel rendering disabled, thus looking ugly. After a few seconds, a repaint occurs, with sub-pixel rendering correctly enabled.

Expected Results:  
Sub-pixel rendering should be enabled.

The problem occurs on a MacBookPro Unibody 15" from early 2010.

This is a regression wrt Firefox 3.6.
(Reporter)

Comment 1

7 years ago
Created attachment 488700 [details]
Sample rendering of a Wikipedia textarea, before scrolling
(Reporter)

Comment 2

7 years ago
Created attachment 488701 [details]
Sample rendering of a Wikipedia textarea, after scrolling

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606075
You need to log in before you can comment on or make changes to this bug.