Last Comment Bug 610189 - Error: aOldNode is undefined
: Error: aOldNode is undefined
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: x86 Windows XP
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Marco Bonardo [::mak]
Mentors:
Depends on:
Blocks: 560198
  Show dependency treegraph
 
Reported: 2010-11-07 01:20 PDT by ithinc
Modified: 2011-04-26 12:20 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image ithinc 2010-11-07 01:20:58 PDT
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101106 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101106 Firefox/4.0b8pre

Error: aOldNode is undefined
Source File: chrome://browser/content/places/treeView.js
Line: 424

Reproducible: Always

Steps to Reproduce:
1. Drag the current tab to bookmarks toolbar
2. Repeat step 1 to have two identical bookmarks in Recently Bookmarked folder
3. Open bookmarks sidebar
4. Open Recently Bookmarked folder
5. Left-click the last bookmarked bookmark
Actual Results:  
The above error is reported in Error Console.
Comment 1 User image Marco Bonardo [::mak] 2011-01-14 16:13:51 PST
I could think the problem is a missing check at line 964
>+if (nodesToReselect.length > 0) {
>  this._restoreSelection(nodesToReselect, aContainer);
>+}

but I cannot reproduce with the steps in comment 0, do you have better steps working in current nightly?
Comment 2 User image Marco Bonardo [::mak] 2011-01-14 16:20:07 PST
even if actually that check would be useless since _restoreSelection early returns, so looks like instead it's a undefined node in _getSelectedNodesInRange node: this._rows[i], so possibly this should use _getNodeForRow(i)...
But I need better steps to reproduce.
Comment 3 User image ithinc 2011-01-15 09:46:42 PST
I have no other reproducing steps. As you said, I cannot reproduce it any more. Maybe it is a RESOLVED WORKSFORME?
If you still want to investigate it, I suggest using 20101106 nightly.
Comment 4 User image ithinc 2011-04-26 12:20:33 PDT
Unable to reproduce it in Firefox 4.0 final.

Note You need to log in before you can comment on or make changes to this bug.