draggable favicons/site icons/placeholder missing after restart from saved session

RESOLVED DUPLICATE of bug 606936

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 606936
7 years ago
7 years ago

People

(Reporter: Stefan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20100101 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20100101 Firefox/4.0b8pre

Firefox does not properly/consistently render the favicons, site icons or placeholder in the address bar when re-starting from a saved session having some tabs open.

Reproducible: Always

Steps to Reproduce:
1. open a few (5) different URLs in disjoint tabs.
2. "Save and Quit"
3. restart firefox
Actual Results:  
Some of the tabs have addressbars which do not show a favicon or site icon nor a placeholder icon.

The "missing icon" is not draggable (i.e. in Order to bookmark).

Expected Results:  
Display favicons/site icons/placeholders as right before the session was saved.

The issue was introduces between

2010-09-30-03-mozilla-central 54798:5a2012482a63 (good)
2010-10-31-03-mozilla-central 56712:18caa24f974d (bad)

bisection gave:

   The first bad revision is:
   changeset:   56393:da395a53dc39
   user:        Sindre Dammann <sindrebugzilla@gmail.com>
   date:        Fri Oct 22 17:13:37 2010 -0700
   summary:     Bug 579868 - Restoring A Normal Closed Tab that was once
   a App Tab causes it to turn back into a App tab when restored
   [r=zpao, a=blocking2.0:betaN]
(Reporter)

Comment 1

7 years ago
I have now reversed da395a53dc39 in the current revision. This works OK and I could not reproduce Bug 579868's issue.
(Reporter)

Comment 2

7 years ago
Problem vanished with http://hg.mozilla.org/mozilla-central/rev/ef7171b16413
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606936
You need to log in before you can comment on or make changes to this bug.