frame link error in javascript console about navigator.js line 117

RESOLVED WORKSFORME

Status

SeaMonkey
General
P3
normal
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: HJ, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001121
BuildID:    2000112120

If you have a frameset loaded with two or more pages, and on one
of the pages are links <a href=""></a> after selecting the link
with your mouse, then the error pop's up in Javascript console!

Reproducible: Always
Steps to Reproduce:
Please visit http://members1.chello.nl/~j.c.drost/mozilla/1.html
for an exact example of this so called 'bug'.

Actual Results:  The pages are loaded, but error's are on the javascript
console. Navigator line 117 is wrong because this one has no properties!

Expected Results:  Loading pages without error's in the Javascript console.

This has been tested with Netscape 6 also the same problem. Netscape
4.76. Microsoft Internet Explorer and Opera 4.02 are doing it
without error's!
(Reporter)

Updated

17 years ago
Keywords: helpwanted, verifyme
(Reporter)

Comment 1

17 years ago
Ok, the source of navigator has changed recently, thus line 117 must be 91 now!
(Reporter)

Comment 2

17 years ago
And yes, still no luck with build: 2000120504
(Reporter)

Updated

17 years ago
Component: HTMLFrames → Browser-General
(Reporter)

Comment 3

17 years ago
Bug 61860 is a dup of this one!
(Reporter)

Comment 4

17 years ago
*** Bug 61860 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
I can't reproduce this under Linux...
(Reporter)

Comment 6

17 years ago
Jag, I just run this test again with build: 2000120504 on WinNT4 Sp6b and it
still produces this error on the JavaScript console:

Error: focusudWindow.location has no properties
Source File: chrome://navigator/content/navigator.js
Line:  91                                 Column: 0

But make sure to click on the link to produce the error!
What else do you need?
Friendly, HJ.
(Reporter)

Comment 7

17 years ago
Still the same in build 2000120804 on WinNT4 Sp6b.

Friendly, HJ.

Comment 8

17 years ago
I can reproduce this on win95 build 2000120804, but does it affect the
navigation in any way? Does it create any bug in your page? Or is it just spam
in the console?
See bug 61385, bug 47338.
Probably a duplicate of bug 61026.
Fabian.
(Reporter)

Comment 9

17 years ago
Nope no problem, spam only
Taking the wrong keywords out.
Keywords: helpwanted, verifyme

Comment 10

17 years ago
WORKSFORME

Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2000122808 Trunk Build

Comment 11

17 years ago
WORKSFORME

Platform: PC
OS: Windows 98
Mozilla Build: 2001010204

Reopen if this reoccurs in the latest builds. Marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
Please first take a look at the provided link, before closing a bug!
There you will see that it's stil the same message, at least on Windows NT.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.