verify email campaign middleware calls

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: ozten, Assigned: jabba)

Tracking

Details

(Reporter)

Description

8 years ago
Can you run the following two commands and pastebin the output, please:

From the middlewear box (or whever, changing the hostname and port)

curl -v http://localhost:8085/201009/email/campaigns/page/1

curl -v http://localhost:8085/201009/email/volume/p/Firefox/v/4.0b6/sig/js_FinishSharingTitle/start/2010-06-05/end/2010-06-13

Updated

8 years ago
Assignee: server-ops → shyam

Updated

8 years ago
Assignee: shyam → jdow
Both of those are returning 404s for me.  Maybe I am running this wrong.
Just for completeness, here is the output from a working (old) middleware query.


wget -O - https://dm-bp-mware01.mozilla.org/bpapi/201005/crash/meta/by/uuid/ca11f2af-da20-427d-80b2-9ee8a2
101105
--2010-11-07 23:44:26--  https://dm-bp-mware01.mozilla.org/bpapi/201005/crash/meta/by/uuid/ca11f2af-da20-427d-80b2-9ee8a2101105
Resolving dm-bp-mware01.mozilla.org... 10.2.74.136
Connecting to dm-bp-mware01.mozilla.org|10.2.74.136|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/plain]
Saving to: `STDOUT'

    [<=>                                                                                                 ] 0           --.-K/s              {"InstallTime": "1285766426", "AdapterVendorID": "1002", "Theme": "classic/1.0", "Version": "4.0b6", "id": "ec8030f7-c20a-464f-9b0e-13a3a9e97384", "Vendor": "Mozilla", "EMCheckCompatibility": "true", "Throttleable": "1", "URL": "http://adserver.ig.com.br/RealMedia/ads/click_lx.ads/www.superdownloadsPAR.com.br/games/1472095324/Top2/OasDefault/sbannerxintel_sdwon_games_081010/superex_download_car_games_2.html/62623136613531323463393738623230", "version": "4.0b6", "AdapterDeviceID": "9712", "ReleaseChannel": "beta", "submitted_timestamp": "2010-11-05T10:29:20.836339", "buildid": "20100914083612", "timestamp": 1288978160.8399999, "Notes": "AdapterVendorID: 1002, AdapterDeviceID: 9712\n", "CrashTime": "1288978132", "FramePoisonBase": "00000000f0de0000", "FramePoisonSize": "65536", "StartupTime": "1288974041", "Add-ons": "testpilot@labs.mozilla.com:1.0.3,toolbar@ask.com:3.5.0.145,{972ce4c6-7e08-4474-a285-3208198ce6fd}:4.0b6", "BuildID": "20100914083612", "SecondsSinceLastCrash":     [ <=>                                                                                                ] 1,048       --.-K/s   in 0s      

2010-11-07 23:44:26 (19.6 MB/s) - `-' saved [1048]



Here is the output from the new query - thats a 404.
wget -O - 'https://dm-bp-mware01.mozilla.org/bpapi/201009/email/volume/p/Firefox/v/4.0b6/sig/js_FinishSharingTitle/start/2010-06-05/end/2010-06-13'
--2010-11-07 23:45:18--  https://dm-bp-mware01.mozilla.org/bpapi/201009/email/volume/p/Firefox/v/4.0b6/sig/js_FinishSharingTitle/start/2010-06-05/end/2010-06-13
Resolving dm-bp-mware01.mozilla.org... 10.2.74.136
Connecting to dm-bp-mware01.mozilla.org|10.2.74.136|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2010-11-07 23:45:18 ERROR 404: Not Found.


I haven't been involved enough in the release to know if something else is missing here - jabba will have to troubleshoot.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
Another reason for 404s is that the new emailCampaign*.py modules aren't being pulled into the list of web services.

The mechanism for this changed from config to being explicit several times in our various branches. I thought we were pushing with explicit modules, but a 404 would be caused by configuration based modules w/o an updated config. 

Please compare scripts/config/webapiconfig.py.dist to scripts/config/webapiconfig.py
If the prod config is missing these, then add them:
import socorro.services.emailCampaign as emailcampaign
import socorro.services.emailCampaignCreate as emailcreate
import socorro.services.emailCampaigns as emaillist
import socorro.services.emailCampaignVolume as emailvolume
import socorro.services.emailSubscription as emailsub
(Assignee)

Comment 5

8 years ago
I was missing a few lines from the diff between webservices.py.dist and webservices.py, although not the ones from comment 4.

I added them and re-ran the curl commands with the following output:


[root@pm-app-generic01 config]# curl -v https://xxxx:xxxxxx@dm-bp-mware01.mozilla.org/bpapi/201009/email/campaigns/page/1
* About to connect() to dm-bp-mware01.mozilla.org port 443
*   Trying 10.2.74.136... connected
* Connected to dm-bp-mware01.mozilla.org (10.2.74.136) port 443
* successfully set certificate verify locations:
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSLv2, Client hello (1):
SSLv3, TLS handshake, Server hello (2):
SSLv3, TLS handshake, CERT (11):
SSLv3, TLS handshake, Server key exchange (12):
SSLv3, TLS handshake, Server finished (14):
SSLv3, TLS handshake, Client key exchange (16):
SSLv3, TLS change cipher, Client hello (1):
SSLv3, TLS handshake, Finished (20):
SSLv3, TLS change cipher, Client hello (1):
SSLv3, TLS handshake, Finished (20):
SSL connection using DHE-RSA-AES256-SHA
* Server certificate:
* 	 subject: /serialNumber=vhiCn2kbHVxmzSKeR6dKZqOK/187nnD0/C=US/ST=California/L=Mountain View/O=Mozilla Corporation/OU=Secure Web Server/CN=*.mozilla.org
* 	 start date: 2009-12-01 03:42:54 GMT
* 	 expire date: 2011-12-02 10:55:27 GMT
* 	 common name: *.mozilla.org (matched)
* 	 issuer: /C=US/O=Equifax/OU=Equifax Secure Certificate Authority
* SSL certificate verify ok.
* Server auth using Basic with user 'xxxxxx'
> GET /bpapi/201009/email/campaigns/page/1 HTTP/1.1
> Authorization: Basic xxxxxxxxxx
> User-Agent: curl/7.15.5 (i386-redhat-linux-gnu) libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5
> Host: dm-bp-mware01.mozilla.org
> Accept: */*
> 
< HTTP/1.1 500 Internal Server Error
< Date: Mon, 08 Nov 2010 16:52:51 GMT
< Server: Apache/2.2.3 (Red Hat)
< Content-Length: 626
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
 root@localhost and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.2.3 (Red Hat) Server at dm-bp-mware01.mozilla.org Port 443</address>
</body></html>
* Closing connection #0
* SSLv3, TLS alert, Client hello (1):
[root@pm-app-generic01 config]# 

[root@pm-app-generic01 config]# curl -v https://xxxxx:xxxxxxx@dm-bp-mware01.mozilla.org/bpapi/201009/email/volume/p/Firefox/v/4.0b6/sig/js_FinishSharingTitle/start/2010-06-05/end/2010-06-13
* About to connect() to dm-bp-mware01.mozilla.org port 443
*   Trying 10.2.74.136... connected
* Connected to dm-bp-mware01.mozilla.org (10.2.74.136) port 443
* successfully set certificate verify locations:
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSLv2, Client hello (1):
SSLv3, TLS handshake, Server hello (2):
SSLv3, TLS handshake, CERT (11):
SSLv3, TLS handshake, Server key exchange (12):
SSLv3, TLS handshake, Server finished (14):
SSLv3, TLS handshake, Client key exchange (16):
SSLv3, TLS change cipher, Client hello (1):
SSLv3, TLS handshake, Finished (20):
SSLv3, TLS change cipher, Client hello (1):
SSLv3, TLS handshake, Finished (20):
SSL connection using DHE-RSA-AES256-SHA
* Server certificate:
* 	 subject: /serialNumber=vhiCn2kbHVxmzSKeR6dKZqOK/187nnD0/C=US/ST=California/L=Mountain View/O=Mozilla Corporation/OU=Secure Web Server/CN=*.mozilla.org
* 	 start date: 2009-12-01 03:42:54 GMT
* 	 expire date: 2011-12-02 10:55:27 GMT
* 	 common name: *.mozilla.org (matched)
* 	 issuer: /C=US/O=Equifax/OU=Equifax Secure Certificate Authority
* SSL certificate verify ok.
* Server auth using Basic with user 'xxxxxx'
> GET /bpapi/201009/email/volume/p/Firefox/v/4.0b6/sig/js_FinishSharingTitle/start/2010-06-05/end/2010-06-13 HTTP/1.1
> Authorization: Basic xxxxxxxx
> User-Agent: curl/7.15.5 (i386-redhat-linux-gnu) libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5
> Host: dm-bp-mware01.mozilla.org
> Accept: */*
> 
< HTTP/1.1 500 Internal Server Error
< Date: Mon, 08 Nov 2010 16:54:18 GMT
< Server: Apache/2.2.3 (Red Hat)
< Content-Length: 626
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
 root@localhost and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.2.3 (Red Hat) Server at dm-bp-mware01.mozilla.org Port 443</address>
</body></html>
* Closing connection #0
* SSLv3, TLS alert, Client hello (1):
[root@pm-app-generic01 config]#
(Assignee)

Comment 6

8 years ago
tl;dr : Internal Server Error on both.
(Reporter)

Comment 7

8 years ago
Is there anything in the logs?
(Reporter)

Comment 8

8 years ago
This is working now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

8 years ago
I had config parameters in the wrong order. fixed now to match the .dist file and now I get 200 OK on both curl commands. Do you need full output?
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.