Javascript pop-up window which should stay focused loses focus

VERIFIED DUPLICATE of bug 77675

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 77675
17 years ago
15 years ago

People

(Reporter: justin, Assigned: joki (gone))

Tracking

({qawanted})

Trunk
x86
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When one is not logged into the credit.com network, upon accessing a page the
user is sent to an authorizer which pops up the login window which the user can
use to log in.  It then uses history.back() to get back to the page that the
access was attempted from and then focuses the login window.  The login window
stays on top in Internet Explorer, Netscape on Linux, and Opera.  On Mozilla it
looses focus and winds up behind the main window. Thanks for the help!
(Reporter)

Comment 1

17 years ago
Oh yes, to have the system prompt you with a login popup click on "Correct
Errors On Your Credit Report"

Comment 2

17 years ago
Confirming bug on Linux as reported. Using commercial build 2000110509.
And on WinNT, same build date, it's even worse: the pop-up window doesn't
appear at all, while the parent window turns blank. Or when I put the URL 
for the top link, "Correct Errors on Your Credit Report", for example, 
directly into the URL bar on WinNT and hit enter, the browser goes blank. 


Here is the URL: 


          https://www.yourcredit.com/code/creditReportDispute.cgi?



On Linux, this triggers some sort of redirect, and the pop-up window appears
above and then behind the original browser window, as the reporter describes -


Browser issue, not engine. Not sure of which component should get it, however.
Reassigning to Browser-General for help on this - thanks 
Assignee: rogerl → asa
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Browser-General
Ever confirmed: true
QA Contact: pschwartau → doronr
Summary: Javascript pop-up window which should stay focused looses focus → Javascript pop-up window which should stay focused loses focus

Comment 3

17 years ago
over to event handling for a look.
Assignee: asa → joki
Component: Browser-General → Event Handling
QA Contact: doronr → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 5

17 years ago
There has been much focus work and window layering improvement since this was 
last investigated.  Please retest with current builds.
Keywords: qawanted
(Assignee)

Comment 6

17 years ago
Possible dupe of 77675 but I still need to look into the claims below that 
sometimes we don't even get popup windows on WinNT.  That would be something 
else.

Comment 7

17 years ago
*** Bug 80696 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 9

17 years ago
[Win98SE, Mozilla 0.9.2 build 2001062815, AMD K6-2 400, 48MB RAM, 3800/128 kbps Cable modem]

Similar testcase: http://www.rabobank.nl

Click "Betalen & Sparen", the orange image/button in the left top corner.
Here's the direct URL:
   http://www.rabobank.nl/data/custom/custom_openwin1300.htm?node_id=1300

That page only contains a small javascript:
   <script language=Javascript>
      window.open('https://bankieren.rabobank.nl/rabo/login.htm?verzoek=REKSAL&Node_ID=1300', 'betalen')
      history.back()
   </script>

This opens a popup login window. For a short time (2 seconds), focus is on this popup window, but then the main window goes back one page in history. Focus is now on the main window and the popup window is hidden behind the main window.

In other browsers (Opera 5.12, NN4.77, MSIE 6.0b2) the popup login window keeps focus and stays on top of the main window.
(Assignee)

Comment 10

17 years ago
I'm gonna go with dupe of 77675 on this one.

*** This bug has been marked as a duplicate of 77675 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 11

15 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.