Formatting text in mail compose window is extremely buggy

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 250539
7 years ago
7 years ago

People

(Reporter: bkvam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.44 Safari/534.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101027 Lightning/1.0b2 Thunderbird/3.1.6

Editing of text formatting in the mail compose in version 3 is extremely buggy. I've selected Times as my email compose font, but whenever I respond to an email it forces the default font to Arial 12. I change the font or the size, but the font will arbitrarily be set back to Arial 12 apparently at random when I start new paragraphs.

Even worse is the general usability of the editor when you apply formatting (bullets, fonts, etc.), or do a lot of cutting and pasting. The editing affects more than the text you select, changes other things, and so on. 

Reproducible: Always

Steps to Reproduce:
1. Set the font in the Composition tab of the options to Times.
2. Reply to a message.
3. Enter a line text before the copied message. It comes out in Arial/Helvetica instead of Times (or Courier, which is the font the original message is usually in).
4. Select the text you just typed in and change the font to Times.
5. Move the cursor to the end of the line and press ENTER. 
6. The text is in Arial/Helvetica again.

Actual Results:  
The editor constantly switches back to Arial/Helvetica 12.

Expected Results:  
The editor should not arbitrarily change the font to one I never selected.

If you try to do any serious editing in the composition window -- moving the cursor around, selecting text, adding bullets, removing bullets, etc. -- the editor constantly does things you don't intend. Sometimes if you cut a line and try to paste it somewhere else nothing appears. Cutting one line will delete an extra paragraph mark and merge the two surrounding paragraphs, changing the formats.

The editor in the previous version of Thunderbird was very solid. It just did what you told it to. I could write lengthy well-formatted messages quickly and easily. This release is extremely frustrating to use. It verges on the edge of being unusable for anything except quick little one-liner emails.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.