Closed Bug 610429 Opened 10 years ago Closed 10 years ago

Include status bar / url indicator as a widget inside toolbar customization.

Categories

(Firefox :: Toolbars and Customization, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 599212

People

(Reporter: kevinar18, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.11pre) Gecko/20100925 Namoroka/3.6.11pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.11pre) Gecko/20100925 Namoroka/3.6.11pre

Note: this is not about bringing back the "status bar," which has been removed, per Bug 574688.

Proposal:
1. Right click on a toolbar -> Customize...
2. Include a "Status" widget that can be added to any toolbar (including the new add-ons bar, if someone wants it at the bottom).
3. The "Status" widget would contain the following expected functionality:
-- window.status targets this field (if visible)
-- active/selected urls on a web page show up here
-- optionally, it could include historical features like the loading status of the page, like "done loading".  However, the primary purpose is showing active links.

Summary:
The lack of status/url indicator at the bottom of the window does present a usability issue for some people... and it likely going to result in many complaints.  It would be nice if we didn't have to resort to add-ons for this feature.  Considering the background this particular features has, this might be a candidate for actually including as an option in Firefox.

Usability considerations:
The status indicator has a long history.  It has DOM access (window.status) and has been used for years in all browsers.

The current move to the top of the page presents a number of usability issues for some people.  Among them include:
* visual distance -- in some cases it may be less eye movement to look down than up; this "may" cause eye strain for a small group.  I personally, have experienced this.
* noise -- the top of the window is very noisy, meaning more mental effort to process all the information in order to pick out the active/selected URL every time.  Subjectively, this makes the interface more difficult to use and/or feel less "smooth" (although most people can't describe why).
* moving target -- the active url length constantly changes it's left side based on the length of the url.  This presents another problem with mental delay as the brain has to search the space for the beginning of the URL before it can start reading it.  (Subjectively, this can give the interface a "sluggish" feel to it.)
* familiarity -- people are familiar with the old style and may prefer it.



----------
Anyways, I hope this proposal might be taken in good taste.  I know there is an add-on... but still maybe this would be worthy enough to actually keep around.  For simplicity, perhaps this new Status "widget" could be tied to the same data as the one used to show the active url in the URL bar.  That way, maybe two different code paths would not have to be maintained ... and maybe all that would be needed is the graphical widget to display and position this info into a toolbar.

Reproducible: Always
Component: Menus → Toolbars
Version: unspecified → Trunk
QA Contact: menus → toolbars
> The lack of status/url indicator at the bottom of the window does present a
> usability issue for some people... and it likely going to result in many
> complaints.

There are many complaints at http://firefox.uservoice.com/forums/57440-firefox-4-beta/suggestions/1217833-bring-back-the-status-bar .
> There are many complaints at
> http://firefox.uservoice.com/forums/57440-firefox-4-beta/suggestions/1217833-bring-back-the-status-bar

Wow, seems like there is a lot of distaste for the "Chrome style".  I have considered proposing a feature for Firefox 4 that would switch to "classic layout" with the menu, buttons, status indicator, in their normal spots ... but I'm not sure I'm willing to go through the frustration of arguing such a thing with the devs.

Anyways, that's also why I haven't brought up this bug report in the mailing list... I'm just not feeling up to arguing over it on the list.  Hopefully, the devs will still take the issues into consideration anyways.
> Wow, seems like there is a lot of distaste for the "Chrome style".  I have
> considered proposing a feature for Firefox 4 that would switch to "classic
> layout" with the menu, buttons, status indicator, in their normal spots ... 
> but I'm not sure I'm willing to go through the frustration of arguing
> such a thing with the devs.

I know how that feels. Can you maybe just post the link on the mailing list and let it argue for itself? If that fails, then there's very little hope anyway.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599212
You need to log in before you can comment on or make changes to this bug.