Tagesschau flash player has no mouse focus in full screen mode

RESOLVED DUPLICATE of bug 596094

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 596094
7 years ago
7 years ago

People

(Reporter: Johannes Falk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1

When I switch to full screen the player is only controllable by keyboard (e.g. space=start/stop, escape=endFSmode).
In other browsers this problem does not occur. The misbehavior started about a year ago and tagesschau refuses having made any changes.

Reproducible: Always

Steps to Reproduce:
1. press start or click in player
2. click full screen icon at lower right
3. try to go back with mouse or to move the slider (impossible)
4. press space to stop and start or esc to end full screen (works fine)
5. back in window mode the player behaves as expected
Actual Results:  
Left mouse does not work at all in full screen

Expected Results:  
The player should behave in full screen like in window mode
Same problem under Vista since April.

Even right mouse has a strange (some times huge) and unusable popup

Comment 1

7 years ago
Confirmed on 3.6.13pre:
Not work on 3.6.13pre:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/cc5b751b8be5
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13pre) Gecko/20101106 Namoroka/3.6.13pre ID:20101106044601

Works on 4.0b8pre:
http://hg.mozilla.org/mozilla-central/rev/a0826dcd6228
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101108 Firefox/4.0b8pre ID:20101108043306
Fixed range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c81efbbacc62&tochange=e5f3177aa3bc
Bug 596094 - windowed plugin subclass is dropped after entering/exiting full screen in flash
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596094
You need to log in before you can comment on or make changes to this bug.