tbpl.mozilla.org not loading

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

Details

(Whiteboard: [needs mv fix], URL)

(Reporter)

Description

8 years ago
tbpl.mozilla.org has not been loading for me ever since I discovered it a week or so ago. The problem seems to be that these two resources aren't loading:

http://build.mozilla.org/builds/builds-pending.js
http://build.mozilla.org/builds/builds-running.js

When I try to load them directly in FF4b6 I get "The connection has timed out".
(Reporter)

Updated

8 years ago

Comment 1

8 years ago
the page loads for me.
(Reporter)

Comment 2

8 years ago
It works for some people, and not for others (according to reports on #developers).

I should also note that it doesn't matter which browser I use; Firefox, Opera and Chrome all fail to load TBPL at the given URL, or the links provided in comment 0.

Comment 3

8 years ago
Are you able to reach the host at all?  Can you telnet to port 80 on that box?

Trying to narrow down where the problem is.
(Reporter)

Comment 4

8 years ago
No, telnet to build.mozilla.org on port 80 waits forever. If you want a lower latency means of chatting to debug, I'm on IRC as jwatt.
(Reporter)

Comment 5

8 years ago
Correction, timed out:

$ telnet build.mozilla.org 80
Trying 10.2.74.128...
telnet: connect to address 10.2.74.128: Operation timed out
telnet: Unable to connect to remote host

Comment 6

8 years ago
Okay, tracked this down.

Hosts at the Mountain View office resolve build.mozilla.org to an internal San Jose IP.  Happens that that IP is reachable through the VPN between the office and the datacenter (through a VPN specifically for build machines).

When an external VPN user connects to Mountain View, that user also gets Mountain View DNS.  The openvpn server isn't advertising a route for 10.2.74.0/24.

Several ways to fix this.  

1. advertise that route.2
2. fix dns such that office folk get the external address for build.mozilla.org

Updated

8 years ago
Whiteboard: [needs mv fix]
(Reporter)

Comment 7

8 years ago
A workaround for me, as pointed out by mrz, is for me to disconnect from the VPN. That indeed gets the build.mozilla.org resources loading as they should, but unfortunately does not solve the problem with tbpl.mozilla.org itself.

I'll probably open a separate bug for that issue and you guys can use this bug for the problem in comment 6.
(Reporter)

Comment 8

8 years ago
Actually with the build.mozilla.org issue out the way, tbpl.mozilla.org loads fine in m-c builds, so I think I must just be hitting a bug in FF4b6. Since the issue seems to be gone on m-c, I'll likely not be filing another bug.

Updated

8 years ago
Assignee: server-ops → network-operations
Component: Server Operations → Server Operations: Netops

Comment 9

8 years ago
comment #8 suggests it's fine now.  Reopen if I'm mistaken.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.