Closed Bug 610654 Opened 9 years ago Closed 9 years ago

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/mozilla-central_leopard-o-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | Response1 == Response0

Categories

(Core :: Networking: Cache, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b8

People

(Reporter: mats, Assigned: bjarne)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files, 1 obsolete file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1289303682.1289307670.30574.gz

s: talos-r3-w7-029
TEST-UNEXPECTED-FAIL | c:\talos-slave\mozilla-central_win7_test-xpcshell\build\xpcshell\tests\netwerk\test\unit\test_bug596443.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | c:/talos-slave/mozilla-central_win7_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | Response1 == Response0 - See following stack:
TEST-UNEXPECTED-FAIL | c:/talos-slave/mozilla-central_win7_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | Response0 == Response1 - See following stack:
TEST-UNEXPECTED-FAIL | c:/talos-slave/mozilla-central_win7_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | Response0 == Response1 - See following stack:
Blocks: 438871
Apparently, httpd.js may swap the order of responses (despite 100ms timeout between them). This fix triggers the second response when the first finishes, enforcing the expected order. Requesting review and approval...
Assignee: nobody → bjarne
Status: NEW → ASSIGNED
Attachment #489167 - Flags: review?(bzbarsky)
Attachment #489167 - Flags: approval2.0?
Comment on attachment 489167 [details] [diff] [review]
Properly controlled response-sequence

OK, thoguh it's not clear to me why the do_timeout stuff is needed at all.
Attachment #489167 - Flags: review?(bzbarsky)
Attachment #489167 - Flags: review+
Attachment #489167 - Flags: approval2.0?
Attachment #489167 - Flags: approval2.0+
(In reply to comment #7)
> Comment on attachment 489167 [details] [diff] [review]
> Properly controlled response-sequence
> 
> OK, thoguh it's not clear to me why the do_timeout stuff is needed at all.

Requesting check-in. The do_timeout is to ensure we trigger the next step after OnStopRequest has returned, otherwise strange effects often pop up.
Keywords: checkin-needed
Backed out in http://hg.mozilla.org/mozilla-central/rev/212a391d3b79

I.e. it must be caused by something else...  will have a look.
Keywords: checkin-needed
Like before but use request-header to carry the desired response to the handler (making it independent of the order of calls to the handler). Requesting review and approval again...
Attachment #489167 - Attachment is obsolete: true
Attachment #489642 - Flags: review?(bzbarsky)
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test 
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1289428929.1289430276.4039.gz

s: talos-r3-leopard-037
TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/mozilla-central_leopard-o-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/mozilla-central_leopard-o-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | Response1 == Response0 - See following stack:
TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/mozilla-central_leopard-o-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | Response0 == Response1 - See following stack:
TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/mozilla-central_leopard-o-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | Response0 == Response1 - See following stack:
Comment on attachment 489642 [details] [diff] [review]
Listeners chained, desired return-value passed as header

r=me
Attachment #489642 - Flags: review?(bzbarsky) → review+
Keywords: checkin-needed
Comment on attachment 489642 [details] [diff] [review]
Listeners chained, desired return-value passed as header

Note that we has approval for 2.0 from the previous patch
Well, I guess "we have" would be a better way to phrase it...  :)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1289577947.1289579633.19283.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test xpcshell on 2010/11/12 08:05:47
s: talos-r3-leopard-005


TEST-INFO | /Users/cltbld/talos-slave/mozilla-central_leopard-o-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js | running test ...

command timed out: 1200 seconds without output, killing pid 310

I'll take straight-up failure over a no output hang any day.
I am hitting this on the newly added Win7 debug unit tests:
https://bugzilla.mozilla.org/show_bug.cgi?id=614956#c5

We need to fix this before we can do the switchover from running _debug_ unit
tests on the Win2003 machines to the Win7 Rev3 machines.

If this is not the same issue please let me know and I will file a new bug.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291225061.1291231409.29838.gz

TEST-UNEXPECTED-FAIL |
c:\talos-slave\mozilla-central_win7-debug_test-xpcshell\build\xpcshell\tests\netwerk\test\unit\test_bug596443.js
| test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL |
c:/talos-slave/mozilla-central_win7-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js
| Response1 == Response0 - See following stack:
TEST-UNEXPECTED-FAIL |
c:/talos-slave/mozilla-central_win7-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js
| Response0 == Response1 - See following stack:
TEST-UNEXPECTED-FAIL |
c:/talos-slave/mozilla-central_win7-debug_test-xpcshell/build/xpcshell/tests/netwerk/test/unit/test_bug596443.js
| Response0 == Response1 - See following stack:
Blocks: 614956