"Move to trash" always moves to [Gmail]/Trash instead of to the specified folder

RESOLVED DUPLICATE of bug 533140

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 533140
7 years ago
7 years ago

People

(Reporter: refear, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101027 Thunderbird/3.1.6 ThunderBrowse/3.3.2

If I choose "Move to trash" with a GMail account, the message will always be moved to [Gmail]/Trash, even if I specified a different folder in the account settings. I set this to /Trash (seen as [Imap]/Trash within GMail), but the mail will always end up in [GMail]/Trash instead. Any other folder name won't work as well.

This used to work fine with Thunderbird 2.0.

Reproducible: Always

Steps to Reproduce:
1. Account settings -> server settings -> When I delete a message: Set it to "Move it to this folder" and define any folder but [Gmail]/Trash.
2. Delete a message.
Actual Results:  
Message ends up in [Gmail]/Trash instead of in the folder given above.

Expected Results:  
Message should be located in the folder given above and NOT in [Gmail]/Trash.
Blocks: 402793

Comment 1

7 years ago
I am having this same problem in.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7
It's current restriction of Tb to avoid unwanted problems around Gmail's particularity of "folder name is dynamically changed by Gmail according to Display Language: selection change by user" which is supported by Gmail's XLIST command use by Tb.

You can perhapas see phenomenon of "icon of a folder you selected is changed to trash can icon, then is changed back to normal folder icon sooner or later" when you changed to "Move to this folder: other than [Gmail]/Trash".
Tb probably internaly forces "trash==[Gmail]/Trash" just after internal setting of "trash==folder selected at trash folder selection UI".

As Gmail's auto-expunging works on a mail to which \Deleted flag is stored unless you disable the Gmail's auto-expunging by advanced feature of Gmail's Lab, current recommendation is like next:
(1) At Server Settings/Move to this folder:, select [Gmail]/Trash, in order to
    avoid your confusion.
(2) Select IMAP delete model of "Remove it as immediately.
    As mail flagged \Deleted is automatically expunged by Gmail's
    auto-expunging, "Move to this folder" model is useless.
    Any mail flagged \Deleted at an IMAP folder(Gmail Label) is always kept in
    [Gmail]/All Mail.
    "Just mark it as deleted" model is useful for [Gmail]/Trash only.
(3) If you really want to delete a mail(and original in [Gmail]/All Mail too),
    manually move the mail to [Gmail]/Trash.
    As original in [Gmail]/All Mail is moved to [Gmail]/Trash, copy in any
    IMAP folder(Gmail Lael) is also deleted.
    This is similar operation to "Delete at Gmail's Web Interface".
(4) Mail in [Gmail]/Trash will be permanently removed after 30 days by Gmail.
    If you don't execute "Empty Trash" nor "delete at [Gmail]/Trash", and if
    within 30 days, you can do "Undo delete" like operation by "Move mail in
    [Gmail]/Trash to [Gmail]/All Mail.
    As seen in bug 620323, all Gmail Label is currently recovered by this
    "Undo delete" like move back operation.
    [Gmail]/All Mail.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533140
You need to log in before you can comment on or make changes to this bug.