Attempt to display local file results in blank window

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
major
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: Crysgem, Assigned: rickg)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

20 years ago
The M5 build (Apprunner ID 1999050423), and many previous builds (unto to the
extent that Mozilla has never succeeded), will, upon loading this page, display
- nothing. No content. The window is intact, the mail-slide is intact, but nil
is displayed. The (simple, single-table) HTML that Mozilla so blankly fears?:

<HTML>
<Head>
<Title>Arc Episodes</Title>
</Head>
<Body>

<Center>

<Table Border=4>
<Caption><H1>Arc Episodes</H1></Caption>

<TR>
<TH>Overall Episode</TH>
<TH>Season Episode</TH>
<TH>Arc Episode</TH>
<TH>Story Year</TH>
<TH>Title</TH>
</TR>

<TR>
<TD><Center>001</Center></TD>
<TD><Center>01</Center></TD>
<TD><Center>01</Center></TD>
<TD><Center>2258</Center></TD>
<TD><Center>Midnight on the Firing Line</Center></TD>
</TR>

<TR>
<TD><Center>002</Center></TD>
<TD><Center>02</Center></TD>
<TD><Center>02</Center></TD>
<TD><Center>2258</Center></TD>
<TD><Center>Soul Hunter</Center></TD>
</TR>

<TR>
<TD><Center>006</Center></TD>
<TD><Center>06</Center></TD>
<TD><Center>03</Center></TD>
<TD><Center>2258</Center></TD>
<TD><Center>Mind War</Center></TD>
</TR>


<TR>
<TD><Center>089</Center></TD>
<TD><Center>01</Center></TD>
<TD><Center>58</Center></TD>
<TD><Center>2262</Center></TD>
<TD><Center>No Compromises</Center></TD>
</TR>

</Table>
</Center>

</Body>
</HTML>
(Assignee)

Updated

20 years ago
Assignee: rickg → chrisd
(Assignee)

Comment 1

20 years ago
Chris -- there's absolutely nothing interesting about the markup on this page,
and it renders find on NT. Can you confirm that this problem exists on NT or
Linux?

Updated

20 years ago
Assignee: chrisd → rickg

Comment 2

20 years ago
Tested using 5/13 Apprunner on Win 95, Win NT, Win 98, Linux(Viewer), and Mac8.5
(5/12 Apprunner).

Page comes up blank on Win 95, Win NT, Win 98, and Linux. Displays OK on Mac.

There is an illegal H1 heading within the CAPTION element (CAPTION can only
contain inline elements). This may be the problem.

Attached two files:
(1) 6107_with_H1.html
(2) 6107_without_H1.html

The second file, which does not have the illegal H1 element, displays fine
across platform.

Comment 3

20 years ago
Created attachment 175 [details]
Document without illegal H1 element

Comment 4

20 years ago
Created attachment 176 [details]
Document with illegal H1 element
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

20 years ago
Ok -- I've taught captions to contain flowelements; strictly speaking, this is
illegal HTML. But what the heck -- I've seen worse.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Local file with cited HTML displays properly with Apprunner (Build ID
1999060808).

Updated

11 years ago
You need to log in before you can comment on or make changes to this bug.