Allow for hiding old showfor selectors from the UI

VERIFIED FIXED in 2.3

Status

support.mozilla.org
Knowledge Base Software
P1
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: verdi, Assigned: rrosario)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
We currently have articles written with showfor blocks for Fx 2. We'd like to retain support for old versions in the wiki markup so that users with later browsers won't see those blocks meant for Fx 2. 

We also want to be able to hide outdated Fx versions from the help with UI.
Target Milestone: --- → 2.3
(Assignee)

Updated

7 years ago
Assignee: nobody → rrosario
Priority: -- → P1
(Assignee)

Comment 1

7 years ago
https://github.com/jsocol/kitsune/commit/47c1710c7aa6ae78a32fd2e5296a4640bfe8f9bd
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

7 years ago
The Fx2 content will be supported in the backend but will never show up in the UI to the user.

Comment 4

7 years ago
fx3, too, I think. Michael, are we ready for that?

Comment 5

7 years ago
Sorry, didn't realized this bug was fixed.
Please add QA steps for verifying this if it does not show up in the UI, or add [qa-], thanks
(Assignee)

Comment 7

7 years ago
You can verify this by adding {for fx3}some text{/for} to a document. The text shouldn't render in the document or preview, and FF3 isn't available in the Help With selector. This is what we mean by having support for fx3 in the backend but its not available in the UI.
Verified able to add {for fx3}, does not render on doc or preview, option not available in help with selector
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.