Closed Bug 610787 Opened 11 years ago Closed 11 years ago

One of Tabs, normally the first of tab list does not close, even when clicking on X, pressing Ctrl+W or middle-clicking it.

Categories

(Firefox :: Tabbed Browser, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 508738

People

(Reporter: gm_ddl, Unassigned)

References

Details

(Whiteboard: [dupeme])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

After 3.6.12 update, one of the tabs, normally the first one of last session (or the one that triggered Firefox to open, and then, the last in the list) does not close even when clicking on X, pressing Ctrl+W or middle-clicking it.

General symptoms are:
*Tab not closing;
*Tab's favicon keeps the 'Loading Animation', even when page is done loading or we pressed Stop/Esc;
*URL at Address Bar does not update. That means, browsing other pages do not affect address bar, it keeps with the first URL entered;
*While Address Bar keeps the same, the Tab Title do change;

I have Firefox 3.6.12 on my Laptop, running Win 7 Pro x64 and that is happening everyday. Today my Desktop at work prompted to update to .12 as well. After restart (saving the tabs session), the Firefox Upgrade Page (that was the last tab, after the ones i had opened) had this symptoms, and not the first of list.

Both computers got some Plugins in common, such as Firebug, AdBlockPlus, Webmail Notifier, etc.

Reproducible: Sometimes

Steps to Reproduce:
I choosed 'Happens sometimes, but not always' but it do happens everyday. I tried reproduce by trying steps starting a new session (and writing 'em down) but couldn't reproduce. But that happens every day, after some usage, including some heavy JavaScript websites, such as Gmail, a Mobile Web Application we use at work, Hotmail, etc.
Actual Results:  
tab list does not close

Expected Results:  
Close the tab.

If it's not a single tab, the thabs had to close until only have one of them. And that one, by closing it, open a new blank tab.

Has been reported here https://support.mozilla.com/en-US/questions/763483

and here as well https://support.mozilla.com/en-US/questions/664386 
(seems keeps happening since topic had new posts after 3.6.12 update)
Version: unspecified → Trunk
So i recorded what happened.

This time, when i opened my Firefox (new session), asked me to Update Webmail Notifier and Firefox Sync. So the first tab was the update page of webmail and the second one sync's one.

The first one did not opened, i think the page timed out, dunno. But the icon was the yellow alert one. When i changed to my start page (firefox/google), the icon stayed the same and so, i noticed the bug happened again and then, i started recording.

I've uploaded at youtube. Sorry for my bad speaking English and video quality.
http://www.youtube.com/watch?v=EpYP4iRBKF0
Duplicate of this bug: 611494
Dupe of bug 508738?
Whiteboard: [dupeme]
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508738
(In reply to comment #62)
> Happens with me as well.
> I've posted some details in https://bugzilla.mozilla.org/show_bug.cgi?id=610787
> with a video on how firefox behaves.

Lets try to get some more information before we head over to bug 508738. Raphael, can you please test with a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles). Does it show the same issue? If not please run your normal profile in safe mode (http://support.mozilla.com/en-US/kb/Safe Mode) and check if an extension is responsible for the problem.
You need to log in before you can comment on or make changes to this bug.