VKB requires pressing enter twice to load a newly typed url

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
P2
normal
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: ozten, Unassigned)

Tracking

({ux-consistency, ux-error-prevention})

Trunk
ARM
Android
ux-consistency, ux-error-prevention

Details

(Whiteboard: [vkb])

(Reporter)

Description

7 years ago
It's taken me weeks to get used to hitting enter twice after typing a url into the location bar.

When I watch others use my Fennec, they often hit this and say the browser is "buggy". What is really happening is they hit enter once and that changes the state of the Text entry, but doesn't load they page. Then they cancel the keyboard and interact with the awesomebar, trying to figure out how to load the url they just typed.

Repro Steps:
1) HTC Evo Launch Fennec
2) Click in location bar
3) Type http://bit.ly/easy-reading
4) Hit Enter

Actual:
Hitting Enter a second time navigates to the new page

Expected:
First Enter should dismiss keyboard and load page
(Reporter)

Updated

7 years ago
Keywords: ux-consistency, ux-error-prevention
Marcia, do you have an HTC Evo? Are you able to reproduce?
Whiteboard: [vkb]
Can't reproduce the bug at all here, is it still happening?
Please reopen if this is still happening.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.