[Mac] Inconsistent right-click behavior on bookmarks

RESOLVED DUPLICATE of bug 300710

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 300710
8 years ago
5 years ago

People

(Reporter: lincolnwebs, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

Right-clicking a bookmark on Firefox for Mac behaves differently in every context.

Bookmarks menu: Right-click launches the bookmark in the current tab.
Bookmark toolbar: Right-click shows options menu (EXPECTED).
Bookmark toolbar in a folder: Right-click does nothing.

On Windows, right-click shows the options menu in all 3 of these contexts. 

This inconsistency is maddening and makes bookmark management very frustrating.

Reproducible: Always

Steps to Reproduce:
1. Right click any bookmark
Actual Results:  
Inconsistent actions depending on context: launch, nothing, or options menu.

Expected Results:  
Option menu.
actually, comparing Windows with Mac is not much useful since each platform dictates its own traditions. And usually Mac does not like context menus.

But since we got other requests, I'm confirming this as an enhancement to be evaluated from the userx experience team.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Summary: Inconsistent right-click behavior on bookmarks → [Mac] Inconsistent right-click behavior on bookmarks

Comment 2

8 years ago
I think this isn't an enhancement wish but an actual issue.

Imagine you want to delete a bookmark being in a folder of your bookmark toolbar (something you want to do many time a day). The only way to achieve that on Mac OS X is currently to open the bookmark (making the browser charge the page), click on the star icon, and click delete. On Linux (and probably on Windows too) you just have to right-click and delete.

Same for renaming a bookmark, opening it in a new tab, creating a new folder, etc. Using bookmarks is quite annoying like that in fact. The contextual menu should be displayed for each case.
(Reporter)

Comment 3

8 years ago
Precisely, Nicolas. This finally drove me off of Firefox. :( I bookmark like a fiend and it simply does not work right on a Mac.

Comment 4

8 years ago
I confirm this bug is really annoying. 

There is no easy way to do simple task on bookmarks that are trivial on Windows and Linux. 
We just can't move, delete, rename, refresh feeds, ... without opening the bookmark manager.

Comment 5

8 years ago
Something like this bug also happens in Linux with Firefox 4.0! Right clicking works at first. Then, after a few times, not only it doesn't work but whenever a menu is opened from the menubar, it disappears instantly, i.e. no menu can be opened. Restarting Firefox solves the last issue.

And I agree: it's very annoying.

Comment 6

8 years ago
The inability to right click on a bookmark within a folder on the bookmark toolbar has been present for as long as I can remember in Firefox on a Mac.  Many people have complained and it has never been fixed.  It annoys me every single day but I can't see it ever getting fixed.

Updated

8 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: DUPEME

Comment 7

7 years ago
Agreed, this is an extremely annoying bug, not an enhancement request.

Comment 8

7 years ago
I just wanted to say that although Linux FF shared this or a similar bug with Mac FF for a while, the bug is fixed in Linux now (FF 7.0.1).

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 300710

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.